WordPress.org

Support

Support » Themes and Templates » Oxygen » [Resolved] Menus doesn't works at IE8

[Resolved] Menus doesn't works at IE8

  • Hi! I’ve been having problems in Internet Explorer 8 with the Oxygen Theme menus. The vertical and horizontal menus are not displayed at IE 8, but they work perfectly in other browsers like Chrome and Firefox. Can anyone help me?

    Blog’s adress: http://www.felipeperin.com.br

    Check the difference of the menu below the header and left menu, using different browsers.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Same here. The oxygen demo seems to be working fine in ie8, but the installed version doesn’t show any menus in ie8. There has to be a difference in the code but can’t find what it is.

    Moderator Andrew Nevins

    @anevins

    Forum moderator

    You need to display block the navigation menu in IE8, because it seems like the JavaScript that displays the menu is broken in that browser verison.

    This change requires a Child Theme
    http://codex.wordpress.org/Child_Themes

    You load new styles through header.php (header.php of your Child Theme) like this;

    <!--[if IE 8]>
     <style>
      .site-navigation .nav-menu { display: block; }
     </style>
    <![endif]-->

    problem solved! Thanks.

    Thanks Andrew!
    Problem solved here too!

    Hello,
    I have exactly the same issue. I tried to add those lines in the header.php of my child theme but it did not work for me.

    Can somebody check my website to show me what I did wrong? :

    http://www.place-nanterre.org

    Thanks in advance

    ps: Excuse me for my english

    Moderator Andrew Nevins

    @anevins

    Forum moderator

    Try putting it just below the </head> element, so you reduce the risk of it being overridden by other styles.

    It didn’t work for me either. Where exactly in header.php should the codes be added and am I suppose to add <?php ?> tags before and after? I’ve tried so many ways and nothing is working. Help!

    hi guys,

    if you still need help try this

    add the code Andrew Nevins provided in your header after line 43 right before the head section ends

    it should make the trick

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Menus doesn't works at IE8’ is closed to new replies.
Skip to toolbar