WordPress.org

Support

Support » How-To and Troubleshooting » Help me get RSS working please.

Help me get RSS working please.

Viewing 15 replies - 16 through 30 (of 30 total)
  • I feel closer now. I’m using the Stuttering Theme and the entire footer.php is as follows:

    <!– begin footer –>
    </div>

    <?php get_sidebar(); ?>
    </div>

    <?php do_action(‘wp_footer’); ?>
    </body>
    </html>

    The references in sidebar.php don’t have the “feed:” in the URL’s but don’t appear to work when inserted. Is there somewhere else I should insert/remove “feed:”?

    Thanks for both your patience and persistence!

    Like I said before, the ‘feed:’ is a protocol that is supposed to open a capable RSS feed reader. When you click on it, your computer doesn’t understand the protocol. It’s similar to ‘callto:’ for Skype and ‘aim:’ for AOL Instant Messenger. Your feed is OK if you left the ‘feed:’ part off.

    Neither Pluck nor RssReader can read it. Both of them detect the same aforementioned error and run the feed through feedvalidator.org to show me that error message.

    Hi Dubbldawg,

    You can use the following links for your Index & Comments Feed.

    http://www.taoofbrian.com/index.php?feed=rss2

    Check you Style Sheet for possible errors. Otherwise you can use this link to obtain your Comments RSS Feeds.

    http://www.taoofbrian.com/index.php?feed=rss2&withcomments=1

    And this is the error that you will get if you leave it as is:

    (The XML page cannot be displayed. Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later… )

    Reference to undefined entity ‘raquo’. Error processing resource ‘http://www.taoofbrian.com/index.php?feed=rss2&withcomment…

    <title>by: Patent Chronicles » Blog Archive » Some blog details</title>

    Someone please set me straight. I don’t think my issue (as outlined above) is an “RSS Reader” issue because I can go to other WP blogs and I have no problem on their sites with the “RSS” links. They show up fine in Pluck. My feed, however, does not.

    I downloaded and looked at several of the documents behind these feeds and found that mine was different from all others in terms of the first line. My first two lines are:

    <meta http-equiv=”content-type” content=”text/html;charset=iso-8859-1″>
    <?xml version=”1.0″ encoding=”utf-8″?>

    …and everyone else’s xml file omits the first line and begins with what is my second line. However, I can’t figure out what is needed to make mine like the others.

    Any clarity would not only be greatly appreciated but make my weekend MUCH more enjoyable if I could put this to rest. 😉

    [See my issue at http://logoswalk.com/journal/wp-rss2.php or http://logoswalk.com/journal/index.php%5D

    I am having a similar problem. Clicking on the RSS link generates the following error:

    XML Parsing Error: xml processing instruction not at start of external entity
    Location: http://keaven.com/main/wp-rss2.php
    Line Number 3, Column 1:<?xml version=”1.0″ encoding=”utf-8″?>

    I get this from your feed, keaven:

    <b>Warning</b>: ob_start(): output handler 'ob_gzhandler' cannot be used twice in <b>/home/kcom/public_html/main/wp-includes/functions.php</b> on line <b>558</b><br />

    I had ” WordPress should compress articles (gzip) if browsers ask for them” checked off. When i unchecked it, it took that error away <shrug>. The rss feed still isn’t parsing correctly however.

    I’ve got a similar, weird problem. My rss feed at http://www.votehawaii.com/wp-rss2.php *seems* to be coming up ok in that I can pull it up in my browser

    EXCEPT:

    1. Pluck doesn’t like or recognize it. It errors out with a 404

    2. The WEIRDEST of all is when I go to feedvalidator.org, it returns to me with a 404 error, yet when I feed it http://www.votehawaii.com, it comes back with “this looks like a web page”.

    the 404 (page not found) error throws me off. it shows in my browser so it can’t be a 404, can it?

    I’m-a goin’ nuts with this. XML validators seem to indicate that they hate the very first line setting the document type, and perhaps something about the 2nd line, but I can’t figure out what to do. I need a white knight or perhaps a really large hammer…;-)

    Line 1: <meta http-equiv=”content-type” content=”text/html;charset=iso-8859-1″>
    Line 2: <?xml version=”1.0″ encoding=”utf-8″?>

    hmm…maybe this can help, when I use this:

    http://www.votehawaii.com/index.php?feed=rss2

    she works like a charm, in Pluck & Feed Validator.

    However when I use this:
    http://www.votehawaii.com/wp-rss2.php

    I get errors all over the place, including “The system cannot locate the object specified. Error processing resource ‘http://www.votehawaii.com/wp-rss2.php’. “

    so to me this smells like something is timing out on the rss2 page. Perhaps it’s related to a server setting that I’m not aware of or don’t have.

    When I use that format I get:

    The following tags were not closed: meta. Error processing resource ‘http://www.logoswalk.com/journal/index.php?feed=rss2’.

    I’m still not there yet…

    Success for me! In another thread, macmanx provided the answer. By disabling my plug-ins it immediatly brought the RSS feeds online. I re-activated them 1 at a time and found a mis-behaving one which I re-downloaded, re-installed, and now everything’s BE-YOO-TEE-FULL. The plug-inwas generating an unwanted first line in my rss feeds. Thanks for ending nearly 2 weeks of angst and groping, macmanx.

    I tried that as well, and now my RSS feeds are working too 🙂 the offending plug-in in my case was the ‘Front Page Gategories’ plugin. not sure why, but all is well now that it’s disabled.

Viewing 15 replies - 16 through 30 (of 30 total)
  • The topic ‘Help me get RSS working please.’ is closed to new replies.
Skip to toolbar