WordPress.org

Support

Support » How-To and Troubleshooting » Help me get RSS working please.

Help me get RSS working please.

Viewing 15 replies - 1 through 15 (of 30 total)
  • WordPress released a very well working product. Have you searched this forum yet to see the replies for the many other people who have been having troubles with their RSS feeds? Take a look and I bet you will find the answer there.

    Well, since a search only ever returns 5 topics, yes I have read everyone and none of them provide the answer I am looking for in plain English.

    Can you please help? I think WP is great. But their RSS no worky.

    Your feed works fine. The “feed:” part is a protocol just like “callto:” for Skype. Your RSS feed is located at http://www.taoofbrian.com/wp-rss2.php

    Please…someone…Bueller? Bueller? Anyone?…

    I’ve spent most of the day trying to get mine to work (I’ve posted under “RSS Help”) but have found nothing close here, the WP Wiki, nor through a myriad of Google searches. Mine is located at http://logoswalk.com/journal/wp-rss2.php. Any help would be appreciated. Thanks!

    dgstinner, it’s not working. I tried opening it with several programs and I get a 404.

    Please help me and servant.

    hmm, i has a similar problem. My rss 2.0 is working ok, but 0.92 says: XML parsing error: <unknown>:13:24: undefined entity. Also, there is another little problem with atom (it looks like my first post ever didn’t have a good <id>.
    Here are my feeds:
    http://www.edux.org/feed/ (is ok)
    http://www.edux.org/feed/rss/ (parsing error)
    http://www.edux.org/feed/atom/ (id error)
    I have changed wp-rss.php and wp-rdf.php after i made a merge of them and there was (maybe because the translated version in spanish). There were diferences in one line:
    wp-rdf.php:
    original: <dc:date><?php echo mysql2date(‘Y-m-d\TH:i:s\Z’, get_lastpostmodified(‘GMT’)); ?></dc:date>
    translated version: <dc:date><?php echo mysql2date(‘Y-m-d\TH:i:s\Z’, get_lastpostmodified(‘GMT’), false); ?></dc:date>
    wp-rss.php:
    original: <lastBuildDate><?php echo mysql2date(‘D, d M Y H:i:s +0000’, get_lastpostmodified(‘GMT’), 0); ?></lastBuildDate>
    translated version: <lastBuildDate><?php echo mysql2date(‘D, d M Y H:i:s +0000’, get_lastpostmodified(‘GMT’), false); ?></lastBuildDate>

    Thanks in advance if there is any tip. Also I installed the wycwyg editor, maybe that?

    Dubbldawg,
    Your feed is located at: http://www.taoofbrian.com/wp-rss2.php

    This appears to work fine. Please try and verify things first before complaining…

    Servant,
    The following line in your feed is borking things. How did this appear as it’s not there by default.
    <meta http-equiv=”content-type” content=”text/html;charset=iso-8859-1″>

    hmm, i have uninstalled all the plugins and the same xml parsing error in the rss. Any help?

    Martinh,
    This is because of the character ñ (&ntilde;) This page gives a technical explanation on this issue.

    thanks ifelse, but dont know why it only occurs with 0.92 and how to solve it. thanks for the cue. and what about the atom first post problem. All the others are ok. Strange, isnt it?

    ifelse,

    I haven’t changed the file and, in fact, re-downloaded it “just in case”. But…I’m woefully ignorant and would appreciate if you could tell me exactly what to do? Should I just delete that line or replace it with something else? Any assistance would be much appreciated. Thanks!

    I see now that if I go directly to it, it works. But, if you are viewing the home page, or index.php and click on the RSS feed link at the bottom, that is where it gets screwy. It looks like it points to the same address.

    Do you have any ideas?

    Hmmm…if I go directly to http://logowalk.com/journal/wp-rss2.php, in IE I get the same error as clicking on the “RSS 2.0” link under “Meta” in the sidebar. It says:

    The XML page cannot be displayed
    The following tages were not closed: meta. Error processing resource ‘http://logowalk.com/journal/wp-rss2.php’.

    In Opera I get:

    XML parsing failed: xml processing instruction not at start of external entity (Line: 2, Character: 0)

    Line 2 currently reads as:

    <?xml version=”1.0″ encoding=”utf-8″?>

    In Netscape I get:

    XML Parsing Error: xml processing instruction not at start of external entity
    Location: http://logowalk.com/journal/wp-rss2.php
    Line Number 2, Column 1:

    <?xml version=”1.0″ encoding=”utf-8″?>
    ^

    Does anyone know the correct syntax for this line and in which file it needs to be corrected? If I were a puppy at the pound I’d be ready to be put to sleep…;-)

    dubbldawg:
    If you have a RSS feed reader that supports the ‘feed:’ protocol, then that program should open when you click the link on your site. If you don’t have a reader that supports ‘feed:’, that’s what’s giving you the 404. Just edit the footer.php file and remove ‘feed:’ from before the URL of your RSS feed.

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘Help me get RSS working please.’ is closed to new replies.
Skip to toolbar