WordPress.org

Forums

NextGEN Gallery
[resolved] HELP: Lost all my Images after uninstall (12 posts)

  1. shahpur
    Member
    Posted 2 years ago #

    Since i couldn't add new galleries after i updated to WP 3.5 i wanted to uninstall the NextGen plugin and install it again as i have read that this could help.

    After uninstalling and reinstalling the plugin i lost all galleries. The Images and the Folders are all there but it seems like all Gallery info in DB is lost.

    How can i undo this? Is there any chance to get my old galleries back? I use WP-DBManager as backup tool and i have a backup from a few days ago. But i can't figure out how to restore that DB information.

    Any clues? Also is there any manual way to add those galleries again with the old data?

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. shahpur
    Member
    Posted 2 years ago #

    I restored my wp db manager backup (it was a pre 3.5 backup so i was afraid that this might cause problems...), and all the images are back now. But the main issue still persists:

    after upgrading to WP 3.5 i can't add images or galleries anymore. But i can see that the folder for the new gallery is created on the FTP, so what could be the reason for this?

  3. DoubleSixx
    Member
    Posted 2 years ago #

    Try creating the folder using Add Gallery / Images. Then click Add new Gallery.

    You can't create a folder / directory via FTP and expect nggallery to find the folder / directory. The folder / directory won't be a part of the nggallery database. So it doesn't exist.

    You can add images to an existing folder / directory via FTP after it's been created. But you have to goto the gallery and click Scan Folder for new images. Otherwise they won't appear in the gallery.

    Good luck.

  4. shahpur
    Member
    Posted 2 years ago #

    Hi,

    thanks for the feedback. maybe i wasn't clear enough, i didn't add the folders via ftp, i used the nextgen gallery function to add the new gallery.

    but i don't get any confirmation that the gallery was added. So when i checked via FTP i could see that nextgen DID actually create the new folder and subfolder fot thumbnails.

    The problem is that the new gallery is not shown in the dropdown so i could select it and upload images to it.

    I didn't add any folder manually it was all done via nextgen admin...

    Also i tried the usual stuff: clear cache, deactivate all plugins, change to default theme. nothing helps.

    I didn't change anything to my general blog setup other than updating a pretty old WP version to 3.5. All plugins, themes and settings remained the same. NExtGen worked without problems prior to the update.

    Could this be a DB rights issue? NextGen does create the folders, but apparently doesn't have the entries in the DB afterwards...

  5. DoubleSixx
    Member
    Posted 2 years ago #

    Well try creating a new one.

    Never know some connection interruption from you to the server may have caused a problem.

    See if you can create a new gallery and add a picture or too just to see if you can insert the gallery into a post.

    Good luck.

  6. shahpur
    Member
    Posted 2 years ago #

    I tried multiple time to add different new galleries now, and it never works. The folder is always created on the server but i can't find the new gallery in the dropdown so i could upload images to it.

    Just tried it again, with the same result: the page where you add a new gallery is just reloaded and i can't find the new gallery in the dropdown box to upload images...

  7. DoubleSixx
    Member
    Posted 2 years ago #

    Maybe try giving the new beta try :

    http://www.nextgen-gallery.com/nextgen-gallery-1-9-11-beta/

    Good luck.

  8. shahpur
    Member
    Posted 2 years ago #

    Hi,

    already tried the latest beta (1-9-11).

    it doesn't change anything sadly...

    this seems to affect many users, hope it will be fixed soon.

  9. photocrati
    Member
    Plugin Author

    Posted 2 years ago #

    @shahpur - Could you try going to Gallery >> Options > General Options, select 'Activate Permalinks', save changes, and let us know if that helps? Also set your WP permalinks to 'Post Name' under Settings >> Permalinks.

  10. photocrati
    Member
    Plugin Author

    Posted 2 years ago #

    @shahpur - If activating permalinks does not resolve this issue for you, would you mind submitting a bug report here, and include your beta test results, along with temp. login information to your site? We'd like to take a closer look at what might be happening on your site.

    Thanks!

  11. shahpur
    Member
    Posted 2 years ago #

    hi,

    i tried both (i already had permalinks active) and it didn't help.

    have sent a bug report with a temp login so you can check the problem out.

    please let me knoy how i can fix this...

    thanks,
    Shahpur

  12. photocrati
    Member
    Plugin Author

    Posted 2 years ago #

    Thank you for sending in your bug report @shahpur ! :) our developers are now looking into this.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic