Help! Just tried to update WordPress. Fatal Error :( (6 posts)

  1. ryanryan2222
    Posted 2 years ago #

    I updated wp tonight and immediately got this message, which now appears whenever I enter my domain name http://www.learnhangul.com

    Fatal error: Call to undefined function wp_get_current_user() in /home/learnhan/public_html/wp-includes/capabilities.php on line 1286

    I am unable to access http://www.learnhangul.com/wp-admin

    I have a backup plugin, backupwordpress, installed. When I typed in learnhangul.com/wp-content/backups, it takes me to this error page:


    I am also unable to enter the cpanel via my hosting service.

    What can I do? Any help is much appreciated as I fear I have just deleted several years worth of content!

    The last backup I have found on my computer is from July 2011, when the site was only in its infancy, and I fear I have lost basically everything.

  2. Hristo Pandjarov
    Posted 2 years ago #

    There's a nightly build that fixes this issue. Download it and install it over your current WordPress installation and it will work :)

    Here's the link: http://make.wordpress.org/core/2013/10/26/tonights-3-7-nightly-build-is-marked-wordpress-3-7-1/

    And a direct link to the zip file: http://wordpress.org/nightly-builds/wordpress-3.7-latest.zip

  3. webstyle
    Posted 2 years ago #

    I have the same issue. Should I just override the files from the archive or make a new install? How I save my current posts in the second variant?

  4. PetLvr
    Posted 2 years ago #

    I got the "Fatal error: Call to undefined function wp_get_current_user() in /home/xxxxxxxxx/public_html/wp-includes/capabilities.php on line 1286" message too. My site was a multisite.

    I just renamed the /PLUGINS/ folder to some temporary name and refreshed and I was allowed in. I then updated all my network of blogs and renamed the /PLUGINS/ folder back ... logged out and I was able to log in okay and so far everything seems to be working. *knock on wood*

    HART (aka PetLvr)

  5. giovanca88
    Posted 2 years ago #

    i have also the same problem, to deactivate the plugin i used the same step as Petlvr..
    but i found out that everytime i reinstall the social group plugin i keep getting this wp_get_current_user() in /home/xxxxxxxxx/public_html/wp-includes/capabilities.php on line 1286" error.

    so my question is how can i solve this problem because it is a payed plugin, and i would like to know where the problem lies and hopefully can someone help me

    thanks u

  6. webstyle
    Posted 2 years ago #

    Yes, disabling the plugins worked. Thanks for the answer anyway.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.