Support » Fixing WordPress » HELP! image upload not working, permissions seem right???

  • The admin image upload tool is no longer working for me. I get the following error, whether I’m using the Browser or Flash upload:

    Unable to create directory /wp-content/uploads/2009/06. Is its parent directory writable by the server?

    But I have double- and triple-checked the permissions, and they are ALL set to read/write/execute — I checked them on all four of those directories, plus the parent /wordpress/ directory where I have stashed wp-content. I’m totally flummoxed, and I can’t get images into my site anymore. Help, please!

Viewing 4 replies - 1 through 4 (of 4 total)
  • I’m having this problem too. I click the icon above my post (when I’m creating a new post) but nothing happens after I click it.

    I just installed WP v 2.8 hoping maybe somehow, magically, that would help. Yeah. Magic never works for me. I also tried deleting the existing (empty) directories for wp-content/uploads/2009/06 (so I deleted uploads, 2009, and 06 folders) and then uploading an image, hoping maybe it would automatically create its own upload folder when it didn’t find one. That didn’t work either, so then I created new directories with those same names and brand new correct permissions assigned. Nada. Same error.

    And I’ve scoured the forums but haven’t found anything that seems relevant to this issue.

    Cavalry? Where are you?!

    Aiigh! Same exact error now when I try to upload a new plugin.

    The site is, if that helps anything. Somebody, PLEASE — help!


    i have the same error and i need to launch my WEBSITE urgently


    does someone know an answer?

    (the problem started for me, when i installed the new version ….(

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘HELP! image upload not working, permissions seem right???’ is closed to new replies.