Support » Fixing WordPress » Help, I keep seeing this when trying to publish post

  • msweirdhacks

    (@msweirdhacks)


    Warning: in_array() expects parameter 2 to be array, null given in /home/weirda5/public_html/weirdhacks.com/wp-content/plugins/hide-featured-image/index.php on line 79

    Warning: in_array() expects parameter 2 to be array, null given in /home/weirda5/public_html/weirdhacks.com/wp-content/plugins/hide-featured-image/index.php on line 79

    Warning: Cannot modify header information – headers already sent by (output started at /home/weirda5/public_html/weirdhacks.com/wp-content/plugins/hide-featured-image/index.php:79) in /home/weirda5/public_html/weirdhacks.com/wp-admin/post.php on line 197

    Warning: Cannot modify header information – headers already sent by (output started at /home/weirda5/public_html/weirdhacks.com/wp-content/plugins/hide-featured-image/index.php:79) in /home/weirda5/public_html/weirdhacks.com/wp-includes/pluggable.php on line 1210

    this code keeps coming up when I try to publish my post and I don’t know why. I use the hide featured image plugin so the featured image doesn’t come up when the full post is opened. I also deactivated the w3 cache plugin because it kept preventing my social share count from showing on mobile.

    Did any of these actions cause this to happen? can someone help?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • CMSDeveloper

    (@jsg9in9nl)

    Hello,

    The “Hide Featured Image” plugin has problems with WP 4.8.x
    Just rename the plugin directory to disable it!

    Moderator Steve Stern

    (@sterndata)

    I recommend asking at https://wordpress.org/support/plugin/hide-featured-image so the plugin’s / theme‚Äôs developers and support community can help you with this.

    And, as pointed out above, disable the plugin until the developer resolves the issue.

    msweirdhacks

    (@msweirdhacks)

    Thanks, disabling the plugin solved the problem. However, my featured image keeps showing at the top of the post when opened. I want the featured image on the homepage but not in the post. is there a way to do this?

    I checked the forum and found this CSS code, but it didn’t work after I added it.

    .single-post .attachment-post-thumbnail {
    display: none;
    }

    Moderator Steve Stern

    (@sterndata)

    I think this is the CSS you need:

    .single-post .entry-thumb {
       display:none;
    }

    To add CSS:

    • If you are using WordPress 4.7 or later, use the “Additional CSS” option in the customizer.
    • If your theme has a custom CSS option, use that to add the CSS shown above.
    • If not, install the plugin Simple Custom CSS.

    Learn to use the Chrome Developer Tools to help you see and test changes to your CSS.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.