WordPress.org

Forums

[resolved] help I’ve done something really stupid (3 posts)

  1. danw700
    Member
    Posted 2 years ago #

    hi
    I was having trouble with the editor & thought I needed to change the login adrress
    it was (this worked )
    http://crosslifechurches.org/blogs

    I CHANGED IT TO
    ftp://crosslifechurches.org/public_html/blogs

    now I can't log in
    what can I do?
    thanks cheers Dan

  2. WPyogi
    Forum Moderator
    Posted 2 years ago #

  3. danw700
    Member
    Posted 2 years ago #

    thanks
    i edit the current theme function with those 2 lines of code fixed

    Edit functions.phpIf you have access to the site via FTP, then this method will help you quickly get a site back up and running, if you changed those values incorrectly.
    1. FTP to the site, and get a copy of the active theme's functions.php file. You're going to edit it in a simple text editor (like notepad) and upload it back to the site.
    2. Add these two lines to the file, immediately after the initial "<?php" line.
    update_option('siteurl','http://example.com/blog');
    update_option('home','http://example.com/blog');

    Use your own URL instead of example.com, obviously.
    3. Upload the file back to your site, in the same location. FileZilla offers a handy "edit file" function to do all of the above rapidly; if you can use that, do so.
    4. Load the login or admin page a couple of times. The site should come back up.
    5. Repeat the above steps, but remove those lines. IMPORTANT: Do NOT leave those lines in there. Remove them immediately after the site is up and running again.
    THIS FIXED IT UP THANKS
    CHEERS
    Dan

Topic Closed

This topic has been closed to new replies.

About this Topic