Support » Fixing WordPress » Help guys….Website loads @ snail's pace if at all

  • Resolved agathoslabs

    (@eventsplug)


    Hi Guys,
    Can someone take a look at my site or provide me with possible reasons why my site is so slow?

    It takes forever to load if at all. In most cases, loading results in a 404 or other sort of error. I have tried my best with DreamHost support but got no where and the same response over and over again.

    This is my last try before dropping DreamHost.

    Thanks

    http://www.agathoslabs.com

Viewing 10 replies - 16 through 25 (of 25 total)
  • esmi

    (@esmi)

    Forum Moderator

    WinSCP is basic looking but pretty good for anyone looking for a free Windows based SFTP tool.
    (Congrats on the archery competition too!)

    Thanks guys (Ipstenu-DH & esmi) for the info.
    Since we’re talking weekends,I saw Kathy Griffin in Napa Valley…..hilarious as always 🙂

    Ipstenu-DH, a friend’s son just took up the sport. Let’s see how long that lasts.

    Think its time to close this one out. Thanks again for all your help Ipstenu-DH.

    Hi Ipstenu-DH,
    I’ve got a problem. One of my plugin called “User Files” is not allowing my users download files uploaded into their accounts. I upload using FTP (now SFTP). Downloading files has never been an issue before DreamPress. Do you know what is likely the problem?
    Thanks

    Which plugin? No offense, but there are 28k plugins just in the WP repository alone, so if you give a link, I’m WAY more likely to be able to debug than with a name 🙂

    (The day people stop naming their plugins the same, I will be so happy).

    http://wordpress.org/plugins/user-files/

    Are they logged in to WP as they download? How big are the files?

    Also? You have wp-super-cache on. That doesn’t play well with DreamPress and is not supported.

    Sorry Ipstenu-DH,
    – “Which plugin?” http://wordpress.org/plugins/user-files/
    – “Are they logged in to WP as they download?” Yes, they must be logged into the website. When the users login, the files become visible.
    – “How big are the files?” They are mostly PDFs and approximately 66-925KB.
    – “You have wp-super-cache on.” I will turn this off. Any recommendation of cache plugin to use in its stead? or do I forget about cache plugins?

    Thanks

    Ipstenu-DH,
    Let me know if you need admin access to my website to troubleshoot.

    Hellooooo Ipstenu-DH,
    See below for a message I from the plugin author:
    “, I have figured out the issue and have altered the plugin to work around it. I would recommend contacting your host to address the problem as they will need to change settings on the backend. The download link was failing because of the inability to retrieve the get variable because it had an extension (query vars failed also in case they ask). For example, the url file=34/file1.pdf would fail while file=34/file1.pdf&s=y would work since the url does not end with the .pdf extension. Oddly, this did not happen in a test with a standalone php file and only with wordpress variables, I suspect this is part of the “optimizations” for wordpress. Regardless the issue is fixed, careful updating the plugin in the future as this could cause it to break again.”

    So that makes a little sense though DreamPress is supposed to look for ? and & in a URL and not cache it.

    I would think, in so far as DreamPress works, we can tack ?nocache on the end. That’s a pretty common cache buster by the way (we picked it because other plugins use it too).

    Ipstenu-DH,
    Can you fix the problem on the hosting/server end? The “fix” mentioned above is just a bandage. It will break when the plugin is updated. Thanks

    Yes and no. The issue is that Varnish is doing what it’s supposed to do 🙂 Caching static files! We want it to cache pdfs, and the URL format of “file=” is way too broad and would cause us to break cache for everyone which would not be a great idea. Instead of causing a problem for one user, we cause a problem for ALL users. Similarly, allowing file_uploads (which is where it stores the files) would cause serious slowdowns for others.

    So I have to present you with some options!

    Options one – Open a ticket with DreamHost and ask us to make you a Custom VCL rule to allow those specific URLs to skip caching. If you do this, please remember to give us the FULL URL of one of the files 🙂 That helps us craft a specific rule for you. It may take us a little while to perfect it, but we certainly can do that.

    Option two – Ask the plugin dev to do a couple things:

    First – Put in a &nocache option in the plugin to bust cache. This will allow for more than just DreamPress to handle the files, as that’s a standard call 🙂 It would obviate issues with most caching systems.

    b) Use pretty URLs instead of file=folder/filename to access the files. This will allow us (and everyone else) to customize rules a lot more easily.

    Option three – Ask the dev to make a custom filter so you can add on variables to the URLs. This is actually a good idea anyway, as it would allow you to put tracking analytics on URLs that don’t call things like Google Analytics (since they’re files and not PHP calls).

    Option four – If you’re not using their insert code and instead are making the URLs manually, just add &nocache to the end. That one I don;t like at all, but hey, use cases are special things!

Viewing 10 replies - 16 through 25 (of 25 total)
  • The topic ‘Help guys….Website loads @ snail's pace if at all’ is closed to new replies.