Support » Plugin: Google Forms » HELP, Google Forms plugin not working, thank you!!!

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author Mike Walsh

    (@mpwalsh8)

    You need to downgrade your Google Form. This comes up periodically. Read through this thread to find links to the downgrade process. It is pretty simple to do.

    I am trying to downgrade my Google Form to a lower version, but it does not seem to work. I am clicking on the big question at the bottom right corner, but the running man and the link which says “back to the old Google Forms” are disabled, they are just grey and are not clickable.

    Now I have found a way to go back to the old google forms (by creating an entirely new google form, he running man is clickable with a completely new form).

    However, now I am getting this additional line of text on my site:
    “/static/forms/client/js/804030430-formviewer_prd.js”

    (This can be seem on on https://research-democratisation.org/)

    How can I remove this redundant line of text?

    I am using the following code: [gform form=’https://docs.google.com/forms/d/e/1FAIpQLSf3ZSxobmPvPdnHvP1byYA9tuVhJw8JDBpoGpGo9AwQdkOQNQ/viewform?usp=send_form’]

    Plugin Author Mike Walsh

    (@mpwalsh8)

    Two things, one a solution, the other a recommendation.

    1. Recommendation: Do not use the “gform” shortcode syntax. You should be using the “wpgform” shortcode. It has far more functionality and is more reliable. To use the new shortcode you define your form using the “Google Forms > Add New” function on the Dashboard and set the various controls as you’d like this. There are two required fields, one is the title, the other is the URL to the source Google Form. Everything else is optional. Once saved, the shortcode syntax will be shown in the list of Google Forms you’ve defined (there should only be one initially). You can also use the form’s permallink to view and test the form.
    2. Solution: Turn off (uncheck) the “Disable HTML Filtering” option in the plugin settings (Dashboard > Settings > Google Forms). Different versions of PHP seem to handle the wp_kses() function differently, this topic has come up before.

    Thank you so much, Mike!!!
    I will try these!
    Thank you!!!

    Thanks again! Both things work now.

    The “submit” button still does not redirect to a custom confirmation/thank you page.

    I have put this under the Google Form options: “The full URL to the optional Confirmation Page: https://research-democratisation.org/thank-you/

    Or do I have to put it like this on my home page, like this?:

    [wpgform id=’148′ targeturl=”https://research-democratisation.org/thank-you/”]

    I have read this thread:
    https://wordpress.org/support/topic/redirectconfirmation-page-url-not-working/, but my issue does not seem to be exactly the same.

    Here is the URL of my GForm:
    https://docs.google.com/forms/d/e/1FAIpQLSf3ZSxobmPvPdnHvP1byYA9tuVhJw8JDBpoGpGo9AwQdkOQNQ/viewform?usp=send_form

    Kindest regards and thank you again so much for your help!
    E.

    • This reply was modified 4 months, 1 week ago by  elitsaa.
    Plugin Author Mike Walsh

    (@mpwalsh8)

    You have a Javascript error on your page when it loads which prevents the redirect from firing.

    yax3sld.js Failed to load resource: the server responded with a status of 404 ()

    You’ll need to resolve that if you want the redirect to work. Checkboxes and some other validation things also will not work if you have any Javascript errors.

    Do you mean my “Thank you” page or my homepage?
    (https://research-democratisation.org/thankyou/
    or
    https://research-democratisation.org/ )
    I am not finding this Javascript error, unfortunately, and have no idea how to resolve it.
    I just had a chat with a WordPress Help-desk admin and she said that she cannot see the error and cannot help me. She advised me to ask you again…
    Or maybe the error comes from the GForm itself?: https://docs.google.com/forms/d/1rFgSBrUcr6n_cT1dDGf2hgekjecsBHKb1xmXuj5pmUQ/edit?uiv=0#

    If this last thing would work, than the whole thing would be working…
    Could you please help me one more time? Thank you sooo much.

    • This reply was modified 4 months, 1 week ago by  elitsaa.
    Plugin Author Mike Walsh

    (@mpwalsh8)

    The problem appears to be on every page in your site so it looks to me like it is related to your theme.

    I would recommend testing the confirmation function with a very simple one field form. Testing with a form that is four pages long is very time consuming. Once you have it working for a simple form, move to your complex form.

    • This reply was modified 4 months, 1 week ago by  Mike Walsh.

    I just spent an hour on the chat with a WordPress help admin.
    Here is part of what he wrote to me:
    “I can see the error, we’re just going to need to do more digging to see what is causing this error. … We’re going to need to do a bit more digging to see what’s at the root of this issue. I’m not sure that this is an issue with our theme, as the plugin you’re trying to use has not been updated in 6 months and others are citing issues as well (I didn’t see this exact issue but I only looked at the most recent reports)…
    Honestly the theme shouldn’t have any issue with this, since this is our Twenty Thirteen theme, one of our very commonly used theme. There isn’t a way to have a WordPress.com site without a theme, you must have one activated.”
    What else can I do?

    Plugin Author Mike Walsh

    (@mpwalsh8)

    It is possible it isn’t your theme that is causing this, that is just my guess. I do know it isn’t coming from the Google Forms plugin. Just because it hasn’t been updated in six months doesn’t mean anything.

    Later tonight I’ll activate the TwentyThirteen theme in my development environment and see what if I encounter the same problem. I don’t think I will but I have been wrong before so I will check again.

    Another simple test is to temporarily disable all the plugins on your site except Google Forms and see if the error still occurs. If the error goes away then one of the other plugins is the source of the error and it is a process of elimination to figure out which one.

    Thank you so much for this!
    I will try this immediately!

    I have now disabled all other Plugins that I could. Three of the plugins say that they are “managed automatically for me”, so I have no way to disable these three.
    Unfortunately, the redirect still does not work.

    I also tried adding a targeturl to my main page, like this:
    [wpgform id=’148′ targeturl=”https://research-democratisation.org/thankyou/”]
    and this did not work either…

    I now not only deactivated, but also deleted all plugins that I could. Still no result…

    Plugin Author Mike Walsh

    (@mpwalsh8)

    The ‘targeturl’ parameter has no effect when using the “wpgform” shortcode. It isn’t registered as a parameter and is therefore ignored.

    This missing Javascript which causes an error is coming from a WordPress Multi-Site plugin called “wpcomsh”. I have no idea what it is and a quick Google didn’t yield anything. Thisi code appears in the header of your site so it is on every single page.

    	<script type="text/javascript">
      WebFontConfig = {"typekit":{"id":"yax3sld"}};
      (function() {
        var wf = document.createElement('script');
        wf.src = 'https://research-democratisation.org/wp-content/mu-plugins/wpcomsh/vendor/automattic/custom-fonts/js/webfont.js';
        wf.type = 'text/javascript';
        wf.async = 'true';
        var s = document.getElementsByTagName('script')[0];
        s.parentNode.insertBefore(wf, s);
    	})();
    </script>
Viewing 15 replies - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.