WordPress.org

Support

Support » Miscellaneous » [Resolved] Help for your Sign-in issues – other than case sensitive username

[Resolved] Help for your Sign-in issues – other than case sensitive username

Viewing 15 replies - 1 through 15 (of 23 total)
  • I can’t commit changes to a plugin I developed, and I’m wondering whether the “Author” name in the info at the top should be the “username” instead.

    It could be denying me access to the plugin, rather than a login failure, because the “Author” name appears like “Sergio Zambrano” rather than “SergioZambrano”.

    I’ll make a few tests with gravatar now to track and replicate the different usernames and emails I saw.

    [UPDATE}
    Here are a few tests I screencasted. The video was edited since I repeated the same test many times, but I cut at the logouts, so it doesn’t affect the tests.

    I use Chrome. in the video you can see me deleting the cookies before. My apologies for the watermarks.

    It shows:

    1) WordPress says “logins are unified”, “no spaces allowed” and “case sensitive” but
    I can log-in to forums using spaces, and no caps for codex.

    2) Codex user is not to the same, though. Codex accepts Sergiozambrano and forum doesn’t.
    No option to edit Codex’s user info nor create a new user. It says “Go to Forum”, BUT logging-in to forums WONT log me in to Codex. So there’s an account I can’t change nor verify (Codex’s)

    3) The broken link in my plugin’s page (graphic sitemap) means the “Author:” line in readme.txt (and plugin’s comments?) means “Username”. Using “Full Name” will break the link to the author.

    Still not able to commit my plugin. WP says everything is ok in their side, but my side keeps showing inconsistencies from WP DB.

    SocialBlogsite – If you’re still having problems, email plugins [at] wordpress.org

    They are the ones who don’t reply anymore.
    Since they can commit with my username from their end, it’s assumed nothing wrong is in “their” side.

    My screenshots and videos show the opposite, though.

    The code used for unified logins between codex, plugins and SVN is mostly consistant. The profiles are also mostly consistant, and you really shouldn’t be messing around with your profile in the codex. Either change it at http://wordpress.org/support/profile/socialblogsite or http://profiles.wordpress.org/users/SocialBlogsite/

    Looking at your info, you SHOULD be logging in with SergioZambrano and SocialBlogsite camel-cased. Everywhere. That should work all the time with forums, Codex and SVN.

    If you look at my profile, you’ll see my userID shows as Ipstenu, capital I. I have to login to the forums and SVN as Ipstenu, with the capital, but the codex (being an older version of MediaWiki and kind of weird) accepts I and i. Don’t get hung up on the Codex, it’s the odd man out and everyone knows it’s odd.

    By the way, notice how the profiles.wordpress URL has your ID camelcased? THAT is how I always know what the ID should be 🙂 if that’s camel’d you should be camel’d. And YES, it totally matters when you add users to have SVN commit access, and even author listing for a plugin.

    Leave your Codex profile alone. It’s useless.

    Ipstenu:

    Thanks for your helpful answers.
    Let me ask you some things anybody would check themselves but since my issues seem to happen only to me, I’d like to know how it goes in YOUR end.

    1) Can you login to forums with “Name Lastname”? (yes, with the space) If you watched my video, you’ll see I CAN.

    And… just to free me up from the doubt:
    2) For codex: If your “real name” has not been updated yet (Seems like before there was no realname fields because I found my username here last week) Can you login with your “real name”? (just change it to “somename” no spaces and try.

    3) As per what you said, do both readme.txt and myplugin.php need to show “YourLogin” as “Author” in order to be allowed to commit?

    Otto told me:

    This doesn’t make any sense. The plugin’s comments have nothing whatsoever to do with “committers”. The allowed committers are set on the plugin’s individual administration pages.

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    You’re making very little sense here, in much the same way that you made almost no sense via our earlier emails.

    – Your username is “SergioZambrano” or “SocialBlogsite”. Period. You don’t *have* any other username.

    – No, you can’t use spaces, because there’s no spaces in your username.

    – The codex has the exact same username and passwords as this forum does. They’re unified. What you set your “Real Name” to is completely and totally irrelevant. You cannot change your login username, at all, ever, period.

    – What is in the readme.txt and the plugin.php file has absolutely nothing to do with who can commit to a plugin. Committers are set on the Plugin’s administration screen. Login, go visit your plugin in /extend/plugins, click the Admin link. You can add committers there.

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    Watched your video. What you’re seeing is that the support forums are smart enough to authenticate you regardless of your added space. My username is “Otto42”, but I can also log in as “Otto 42” or “O t t o 4 2” if I want. That doesn’t change what my username is, and that won’t make it magically work elsewhere, especially not in SVN (which is *very* picky.. name and case matter there).

    Stop trying to use weird usernames. Your username is “SergioZambrano”. Use that. As I just typed it in.

    There’s nothing wrong with your account that I can find and there’s nothing wrong with our system. When you gave me your password, I tried it, and it worked fine.

    Do a re-checkout of your plugin if you have to. Maybe something is wrong with your working copy.

    bbPress strips the spaces, Otto. That’s kind of awesome in a weird way. o.O

    (The readme and plugin.php only matters in terms of who gets listed as an author on the plugin page. They’re also case sensitive, but as Otto said, putting in the wrong name will note revoke your access.)

    Yes, I don’t make much sense because my first language is not english.

    Ok, you have answered most of the screencast.
    Still not answered where the different email came from in the original screenshots. cuentanumerouno@… was not used in codex until I created it last week to test existence. It was used years ago, so I assume some backup came up to life for a few seconds when I was testing it.

    support forums are smart enough to authenticate you regardless of your added space

    Yeah… that magic should be translated to the “Author” link in each plugin footer or otherwise noted to us Plugin creators so we don’t use “Our Name” instead, or the link gets broken.

    Stop trying to use weird usernames. Your username is “SergioZambrano”. Use that. As I just typed it in.

    If I had had an answer to my first two screenshots (same user ID#, different email) and had been able to commit in first place, I wouldn’t be “trying weird usernames”. I call it “tracking an issue nobody found”.

    There’s nothing wrong with your account that I can find and there’s nothing wrong with our system. When you gave me your password, I tried it, and it worked fine.

    For me, to be told logins are unified and then finding all these inconsistencies, how do you want me to call it other than “something wrong”. Anyway, no tests no answers.
    I understand you don’t find anything wrong in your side, but everything in my side is subject to what your side allows me and how much I trusted or misunderstood your documentation.

    Do a re-checkout of your plugin if you have to. Maybe something is wrong with your working copy.

    I made so many tests with my plugin that now that I added a new user (Otto offered to do it but seems didn’t have the time) and am able to commit, I found the “tags” directory was scheduled to be removed. I fixed that “updating” the dir, but now SVN throws:

    xecute: Commit
    Error: Error while performing action: Commit failed (details follow):
    MKACTIVITY of '/!svn/act/******-****-****': Could not read status line: Connection reset by peer (http://plugins.svn.wordpress.org)
    Ready
    
    Execute: Commit
    Added: /Users/sergio/Documents/WP_Plugins/graphic-wp-sitemap/tags/1.1.0
    Error: Error while performing action: Commit failed (details follow):
    Server sent unexpected return value (405 Method Not Allowed) in response to MKCOL request for '/!svn/wrk/****-****-****-****/graphic-wp-sitemap/tags/1.1.0'
    Ready

    I used rapid SVN and DreamWeaver. DreamWeaver unlike rapidSVN notifies me the login was successful, but still a throws 403 for the main user.

    So, as you can see, I’m stuck again, and the original user permissions is not fixed.

    Thanks Mark. My original username commits fine now.

    I don’t know what you did, but if you didn’t do a thing, let’s keep this open so others can contribute with their input until it gets fixed or the word on how to fixe it is spread.

    If you did, let us know what! or how to avoid it next time.

    Removing the whole local copy fixed the last errors. That was one of my first tests but it didn’t work, so you must have done something.

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    FYI: The codex is wholly irrelevant. Whatever you have set in there has no meaning anywhere outside of there. It has integrated logins, not integrated profiles or anything else. You can put any email you like there and it won’t affect anything else anywhere.

    The “(405 Method Not Allowed) in response to MKCOL” message is what happens when you are trying to add a directory that already exists in the SVN. Most likely, Mark deleted that directory, allowing you to add it.

    See, you’re trying to commit a change (adding the /tags/1.1.0 directory), but that change conflicts with what is already in there. That’s why I suggested creating a new checkout and starting your working copy fresh from that checkout. Whatever you’ve did locally borked up your working copy.

    You can modify committers to your particular plugin by going to this page and putting in the proper usernames:
    http://wordpress.org/extend/plugins/graphic-wp-sitemap/admin/

    Note, the plugin is currently owned by the “SocialBlogsite” account. You’ll have to be logged in as that to modify the committers.

    What is in the plugin’s readme.txt file doesn’t change who is allowed to commit to a plugin, it just changes the display of the plugin in the directory.

    Note, the plugin is currently owned by the “SocialBlogsite” account. You’ll have to be logged in as that to modify the committers.

    Yes, I removed the original user as another way of fixing a nonsense error with nonsense tests. That’s the way new cures are discovered 🙂 (and the same way they are banned by FDA in name of “science” hehe)

    I hope you guys can tell me what you did, because the occurred shouldn’t fix a user but a plugin local copy at most.

    1. The original committer was throwing errors for ANOTHER plugin as well, in TWO different SVN clients, so…
    2. The commiting issue was oddly fixed by committing from a new account,
    3. then I was able to see the corruptness of files,
    4. then I deleted the whole thing and started from new checkout,
    5. proofs so far shown me the error was “tags” directory “scheduled for deletion” affecting OWNER only, I went ahead and removed the original commiter from the list and changed the commiters and “Author” from the plugin code.
    6. Oddier, the OTHER plugin started working

    The only thing I can think of is user/plugin combinations needing manual “approval”, like a flag or something, only gotten at some early stage, and when changing the line “Author” in the plugin the checksum doesn’t work anymore, nor the approval is requested to WP.org admins.

    No, there’s no manual approval. Once you get the repo access, you’re good to go.

    It’s possible your SVN setup on your PC was goobered because of the corrupt files.

    No, there’s no manual approval. Once you get the repo access, you’re good to go.

    Well, any other approval, even automated, done around the initial stages of a plugin creation which could be not re-done when changing the only commiter’s “Author” would explain it.

    It’s possible your SVN setup on your PC was goobered because of the corrupt files.

    It’s true, but the only thing that changed in the local copy of that plugin when became corrupt was the profile update and the “Author” name, which I reverted as soon as I got the first error, no success.

    So the error must be on the server, which is the one who gives or denies privileges. My local copy doesn’t decides the access. The client just sends the credentials I entered when “logged in”. I just looked for my username in the current (theoretically working) .svn files and there’s no mention of the username.

    AND even if this is not so, both users should work or fail the same. Instead, a new user worked while another didn’t.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Resolved] Help for your Sign-in issues – other than case sensitive username’ is closed to new replies.