Support » Plugins » Help, does WP 2.5 & XML Sitemap Gen play nice??

  • I’ve got 2.5 and since the upgrade, Sitemap generator is not working.

    I get this error:
    “The last run didn’t finish! Maybe you can raise the memory or time limit for PHP scripts”

    I’ve increased memory to 32M – execution time to unlimited. Google webtools shows errors ALL over the place and tells me “Line 126 Parsing error”

    My existing plugins on Cutline 2.1 – 404 notifier, akismet, All in one SEO, Feedburner FeedSmith & wp-cache.

    Should I downgrade, uninstall/reinstall something?? I’m stuck….

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’ve also had sitemap trouble. When I submitted one to Google webmaster tools, it showed a 303 error. I’ve now turned off the plugin and deleted the sitemap files and seen an increase in (20%) site traffic. I also down a manual site submit to Google, to get the current content indexed.

    I’m also facing same problem, right after upgrading to WordPress 2.5. Sitemap generator is not working and ends with following error:

    “The last run didn’t finish! Maybe you can raise the memory or time limit for PHP scripts”

    Earlier on WordPress 2.3.3, I was able to generated sitemap with just one click and it used to take between 5-15 seconds.

    Might want to talk to your host about the memory issue. I just intentionally deep-sixed my database last night and started over with a shiny brand new one and rebuilt my sitemap with no problems. Didn’t even take a couple of minutes. I’m using WP 2.5 & XML Sitemap Gen

    Here’s my experience with the Google XML Sitemaps plugin and upgrading from 2.3.3 to 2.5 and now to 2.5.1. Basically I’ve had no problems with the plugin at all so here’s some info in hopes that it might help the folks who might be having memory problems

    For me: The debug information comes through with no errors, I can rebuild the sitemap successfully (actually turn around time to page refresh was about 12 seconds):

    The building process took about 2.76 seconds to complete and used 20.25 MB of memory.

    Checking with Google’s Webmaster Tools, my submitted sitemaps show no errors, my site is correctly indexed in accordance with my sitemap and “robots.txt”. No errors.

    I ran a test post to try and duplicate some of the problems of publishing taking over 50 seconds for some folks and from time I hit the “Publish” button to the actual moment the post was published was Approximately 11 seconds. The sitemap rebuilt normally at time of publish:

    The building process took about 6.37 seconds to complete and used 20.25 MB of memory.

    One of the things I did quite awhile ago was to stick a “php.ini” file (normally found in your root directory…I made a copy of mine) into my “plugins” folder where I was concerned about script functions that took more than the default 8 or 16 MB’s of memory to execute. Also, after a major upgrade, it’s not uncommon for certain scripts which ran fine before to require more memory to execute the first few times. I don’t know why this is exactly but I’ve encountered it more than once.

    Here’s a couple things you can try:

    1. in the Google XML plugins settings, set memory limit to 32 and save your settings. Then try rebuilding again. If successful then try another post and see what happens.


    2. In any WordPress install, your host should have put a “php.ini” file in your root directory. Bring this file up in your favorite editor and look for a section called “Memory Resources” or the equivalent. It should have a couple of lines that look like this:

    max_execution_time = 30 ; Maximum execution time of each script, in seconds
    memory_limit = 32 ; Maximum amount of memory a script may consume (8MB)

    If memory limit isn’t equal to 32 (it might be set to 16 for example) then change the number to 32. You might also want to make sure that the “max_execution_time is set to a minimum of 30 also. Once that’s done, save it back to your root directory on your server. Now try to rebuild your sitemap.

    If you encounter the same problem then make a copy of that “php.ini” file and drop it right into your “wp-content/plugins” directory and try rebuilding once more. I’d be surprised if one of these solutions didn’t solve your problem.


    Hi all,

    thanks for the feedback! There was a change in the WordPress 2.5 caching system which resulted in a database query for every post when the sitemap was created. Because of this, it is likely that the script run into the memory or time limit.

    I’ve added a workaround in the new release which fixes this issue. You can get it here:

    I’m also working on the new major version of the plugin which is split into several files, so only the PHP code which is needed for the current request is loaded. That means that only a very small “code loader” is active on every page load and the sitemap generator itself is just loaded when you really want to rebuild the sitemap.

    You can help me by testing the new test release (also known as “development version”). Note that this version might not work completly, but it would be great if you help me and report what’s not working 🙂

    The current development version is always here:

    Please note that if you update to this version, the plugin should be automatically disabled afterwards since the filename of the core plugin file changed. You’ll need to activate it again at the plugin page.

    Thanks and best regards,


    Hi Arne,

    I’ve also been having a problem. Strangely I have 2 blogs running 2.5.1 and one has no problems with the plugin but the other just refuses to play nicely.

    I have tried both the development version and the version as well as adding php.ini files but still nothing but a blank screen after 6 or 7 minutes and only a half completed sitemap.xml file to show for it, nothing at all created in the .gz version…

    One thing I notice is that if I remove the plugin from the server and then re-install it, it still shows the data from the previous attempt i.e. as soon as i activate it it says the previous attempt didn’t finish etc… almost as if it’s kept it in some sort of cache, I’m wondering if this is causing the problem with trying to use the the newer versions which seem to have worked for others?

    Like I said, the other blog with the same host has no problems at all…

    Any help would be appreciated 🙂

    The same problem here:

    # The last run didn’t finish! Maybe you can raise the memory or time limit
    for PHP scripts. Learn more
    # The last known memory usage of the script was 15.75MB, the limit of your
    server is 64M.
    # The last known execution time of the script was 0.6 seconds, the limit of
    your server is 120 seconds.
    # The script stopped around post number 908 (+/- 100)

    and in debug file is something like this:

    Errors, Warnings, Notices

    Notice: Undefined index: debug in
    /home/business/public_html/wp-content/db.php on line 645

    Notice: Undefined index: debug in
    /home/business/public_html/wp-content/db.php on line 646

    i receive this when i want to include in the sitemap the tags
    PS the server limit don t have any problem with the plugin
    some help will be great

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Help, does WP 2.5 & XML Sitemap Gen play nice??’ is closed to new replies.