WordPress.org

Forums

Virtue
[resolved] Custom home page not showing as Front page (10 posts)

  1. pjfortune
    Member
    Posted 1 year ago #

    I spent alot of time building a custom home page(without using the theme home page options)(used page builder for a whole new custom home page) - but when i set WordPress to use my new custom/static page as the front page, it does'nt load my custom page - it loads a default theme home page???

    How do i get my custom home page to be the front page?

    PLEASE HELP!

  2. hannah
    Kadence Theme Support
    Posted 1 year ago #

    Hey, do you have page content enabled in the homepage layout manager in theme options > homepage layout? Do you mind posting a link?
    Hannah

  3. pjfortune
    Member
    Posted 1 year ago #

    Hey Hannah,

    I tried it with the page content enabled and disabled.

    I built a custom page using the page builder without making use of the Theme options for the home page as my intention was for my custom built page to replace the original theme home page.

    My custom page displays as intended when not set as the Front page, but when i set it to display as the Front page - the default theme home page still displays and seems to override my custom home page despite following these steps:
    "Settings" > "Reading" > Front page to display as: "Static page" > "Choose Front page"

    Normally i just have to choose "static page" & choose the static page that will be the home page - but it does'nt seem to work here? I think i am missing something simple?

  4. hannah
    Kadence Theme Support
    Posted 1 year ago #

    So you definitely want page content enabled in the homepage layout manager. I assume you've published the your page? Can you post a link?

  5. pjfortune
    Member
    Posted 1 year ago #

    Hey Hannah, yes i have published the page and it works fine when its not set as the home/front page, but as soon as i set it as the Front page - it does'nt load, the theme home page loads.

    I never used the home page layout manager, cause i added a new page and built it from scratch using the page builder plugin. But the theme does'nt seem to allow me to set this page as the front page.

    Say i click "add new page" from the "pages" section, named it "Home" & built it using the page builder plugin without using the themes home page layout manager or theme options, how do i set this new page as the Front page?

  6. hannah
    Kadence Theme Support
    Posted 1 year ago #

    From there you would go to settings > reading and set the front page displays as a static page and choose home as the front page and nothing for the posts page. Then you would go to theme options and enable page content in the homepage layout manager. But I think that you've already done all this? Can you please post a link so I can see what you mean by theme home page.

  7. pjfortune
    Member
    Posted 1 year ago #

    Sorted, thanks Hannah!

  8. saksaksak
    Member
    Posted 11 months ago #

    Thank you Hannah, you just solved my problem. I had also forgotten to enable page content...

  9. candiluna
    Member
    Posted 4 months ago #

    I have a similar issue, however it's all my pages as opposed to just the home page. All my static content in the page builder is overridden by just all of my posts. The home page I want this way but my other pages have been static. Any idea?

  10. Kadence Themes
    Member
    Theme Author

    Posted 4 months ago #

    candiluna,
    Please post in your own topic. Include a link also.

    And test your permalink settings make sure you have them set on default as a test.

    Kadence Themes

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic