Support » Fixing WordPress » Help! Can’t import TypePad to WordPress

  • Hello all. I’m a Mac user trying to migrate my TypePad blog to WordPress. I’ve read a lot of the how-to guides on this but they aren’t resolving my problem. Please help!

    In short, I used the importer in WP 2.7 to import my posts, but they don’t appear anywhere on my WP site.

    In long, here’s what I did:

    1) Used TypePad’s Export function to move the posts to my hard drive. It created as a file called download-export.htm. Curiously, none of my permalinks or any URLs were in this file. Tried this several times with the same result.

    2) Coverted this file to text by saving that doc as a text file, cutting and pasting it to TextEdit, and saved that file using Format < Make Plain Text. I gave this file the name “mt-export.txt”.

    3) FTPd the mt-export.txt to my wp-content folder.

    4) At WordPress, under Tools, I followed the procedure to import the mt-export.txt folder. I mapped to the existing author.

    5) Damn! No new posts or comments or anything appear on my site. It’s as if I’d never done anything at all.

    If it helps, the typepad site I’m importing from is here:

    And the site I’m importing to is here (it’s just a messy placeholder):

    What am I doing wrong? I’ll try anything!

Viewing 4 replies - 1 through 4 (of 4 total)
  • I am having the SAME problem. If you figure anything out please let me know!

    Every few months I check the forums to see if this problem has been resolved. It has not and no administrator will touch it… everyone who asks this question is left hanging.

    I found some tutorials online. Here:
    and here:

    The second one, I wrote to the guys and I’m going to hire them to do the job for me. $300/blog (I can get a discount if I do more than a couple). I’ll let you know how it goes.


    Just wanted to update this as I had the same issue today. I had set up the weblog and spent some time fiddling around installing plugins etc before attempting to import entries. I believe that was the problem. I disabled all the plugins and was then able to import without issue.

    Hopefully this will be helpful to somebody.

    I am having exactly the same problem myself.. Couple of questions:

    1 – does uninstalling plugins work?
    2 – does using the FTP route work better than the file upload?

    I really need to transfer the updates from Typepad to WP for a site I’m building for a client. I’d very much prefer not to spend a chunk of the profit on the work paying a third party to do the work for me …


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Help! Can’t import TypePad to WordPress’ is closed to new replies.