Support » Fixing WordPress » Help! Can’t edit post (includes error message)

  • Anonymous

    I tried going to manage/posts and clicked on the title of the post I wanted to edit, and this is what I got:

    Warning: require(Text/Diff.php) [function.require]: failed to open stream: No such file or directory in /usr/local/ndn/web/oneclicks/wordpress/wp-includes/wp-diff.php on line 4

    Fatal error: require() [function.require]: Failed opening required ‘Text/Diff.php’ (include_path=’.:/usr/local/ndn/web/oneclicks/wordpress/wp-includes’) in /usr/local/ndn/web/oneclicks/wordpress/wp-includes/wp-diff.php on line 4

    It does this for both posts I selected!

    A little background information:
    1. I was able to edit earlier this morning w/o a problem.
    2. Earlier this morning, when I went to “view site” I noticed that it had the option to “edit post”. I was concerned that anyone looking at the site could edit my post. So I deleting all of my cookies and internet files and history, and went to my site; I saw that the “edit post” option was not there.
    3. I added myself as an author, and I tried to change my name as admin so that it would appear not as “admin” but Anne-Marie.

    That is all I did today between when I was able to edit my post and not.
    fyi: my URL is :

    THANK YOU for anyone who can help!

  • The topic ‘Help! Can’t edit post (includes error message)’ is closed to new replies.