WordPress.org

Forums

Help: Can't delete post's (13 posts)

  1. ph33rgear
    Member
    Posted 9 years ago #

    Whenever I try to delete post's in the admin menu under Manage. I click on delete, and the page just reloads quickly but doesn't delete the post.

    Now I was also wondering if anyone could tell, me if I went into my database, and just erase the post's I didn't want manually. Would I get db error's after that?

  2. citeewurkor
    Member
    Posted 9 years ago #

    You could, but it would be advisable to back up your database first.
    But it seems the first problem should be addressed. Namely, "Why can't you delete posts."
    Using 2.0? Recently upgraded?

  3. ph33rgear
    Member
    Posted 9 years ago #

    using 2.0 yes
    Fresh install

    I have 4 plugins on the go sitemap,auto links, video manager, subscribe me.

    I can't login either, the only way i seem to be able to login is by hitting the edit link beside any post's. When ever i use the admin login it just refreshes the screen and nothing again, but once I go back the the mainsite page it shows the edit links for me to get in.

    Any ideas, would php be the prob at all?

  4. citeewurkor
    Member
    Posted 9 years ago #

    can you go directly to:
    http://www.yoursite.com/wp-admin/index.php
    Your admin panel?
    Of course, if you're installed in a directory, you'll have to reflec the change in the URL.

  5. ph33rgear
    Member
    Posted 9 years ago #

    no sir,

    I get the same thing I get on the main page. But the URL is http://www.yoursite.com/wp-admin/index.php

    BTW, thanks for taking the time to help me =)

  6. citeewurkor
    Member
    Posted 9 years ago #

  7. ph33rgear
    Member
    Posted 9 years ago #

    Well i tried changing it, and nothing at all seemed to happen, no better no worse.

    Hmm any more idea's? php version, old call signs, the mods? most were just drop in plugins and go, add a line in the head.

    But i did notice it do it on fresh install. So server settings?

  8. ph33rgear
    Member
    Posted 9 years ago #

    yeah I just installed it on another domain to test, and it deos that login prob from the start... hmm

  9. citeewurkor
    Member
    Posted 9 years ago #

    Maybe there are some weird permissions going on server side.
    But I can't make any recommendations there. I'm not a permissions guru.
    You could try to TEMPORARILY change the permissions on the admin folder to 777 and see what happens. DO NOT FORGET to change it back to default.

    Who's your host?

    for some weird reason, I think I've heard of this problem before, but for the life of me, i can't remember when or where.

  10. ph33rgear
    Member
    Posted 9 years ago #

    my host is http://www.oxeo.com and some of my other scripts were acting up, something to do with my scripts trying to use old php calls or something hehe, but we added something to the .htaccess files and they were ok maybe I should try the same.

    I'll let ya know in a few mins

  11. ph33rgear
    Member
    Posted 9 years ago #

    what was added to the other two htaccess files was "php_flag register_globals on". I tried it, and nothing.

    weird, I'm gonna keep trying.

  12. ph33rgear
    Member
    Posted 9 years ago #

    Apparently was a prob on my server it is fixed now, although it still doesnt delete the post's weird...

    login is fixde tho

  13. citeewurkor
    Member
    Posted 9 years ago #

    Hmm.. Well, at least you can reach the admin panel now. (sorry, had to go sleep for 8 hours...)

    But you still cannot delete posts.
    hmm...
    Hmm.. ok did a little searching..
    try disabling javascript and see if that helps
    http://trac.wordpress.org/ticket/2173
    Just a hunch...
    Also, be sure that you haven't changed your admin's role or something.
    You can check that in your dashboard's users page.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags