Support » Plugin: WP eCommerce » Help, Braintree requires xmlwriter error

  • fivestarg

    (@fivestarg)


    Hi,

    I’m getting the below errors after installing your plugin. My site goes completely down when the plugin is activated.

    My Setup:
    -Wordpress Version: 4.9.8
    -PHP Version: PHP7.0
    -xmlwriter is installed
    -Apache2
    -OS Ubuntu 16.04

    ERROR MESSAGES
    —————————————————————————————
    Fatal error: Uncaught Braintree\Exception: The Braintree library requires the xmlwriter extension. in /var/www/wordpress/alphanode.online/public_html/wp-content/plugins/wp-e-commerce/wpsc-components/merchant-core-v3/libraries/pp-braintree/sdk/lib/Braintree.php:18

    Stack Trace
    1.
    PPrequireDependencies()
    /var/www/wordpress/alphanode.online/public_html/wp-content/plugins/wp-e-commerce/wpsc-components/merchant-core-v3/libraries/pp-braintree/sdk/lib/Braintree.php:23
    2.
    require_once(‘/var/www/wordpr…’)
    /var/www/wordpress/alphanode.online/public_html/wp-content/plugins/wp-e-commerce/wpsc-components/merchant-core-v3/libraries/pp-braintree/pp-braintree.php:39
    3.
    WPEC_Braintree_Helpers::includes()
    /var/www/wordpress/alphanode.online/public_html/wp-content/plugins/wp-e-commerce/wpsc-components/merchant-core-v3/libraries/pp-braintree/pp-braintree.php:20
    4.
    WPEC_Braintree_Hel in /var/www/wordpress/alphanode.online/public_html/wp-content/plugins/wp-e-commerce/wpsc-components/merchant-core-v3/libraries/pp-braintree/sdk/lib/Braintree.php on line 18
    /var/www/wordpress/alphanode.online/public_html/wp-content/plugins/wp-e-commerce/wpsc-components/merchant-core-v3/gateways/braintree-credit-cards.php:8

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Justin Sainton

    (@justinsainton)

    Hi @fivestarg!

    Is it possible for you to enable XMLWriter in PHP, or ask your host to do so for you? That would be the way to fix this. I noticed you said it was installed – but the Braintree code running here is doing a simple extension_loaded( 'xmlwriter' ) check – so if it is loaded, there’s something deeper at a server level here to uncover.

    fivestarg

    (@fivestarg)

    Thank for the quick reply!

    I did have to install php7.0-xml as it was not installed.
    The I added the extension setting in php.ini and checked the install.

    this command: php -i | grep “xml” give me the following output

    php -i | grep “xml”
    /etc/php/7.0/cli/conf.d/15-xml.ini,
    /etc/php/7.0/cli/conf.d/20-simplexml.ini,
    /etc/php/7.0/cli/conf.d/20-xmlreader.ini,
    /etc/php/7.0/cli/conf.d/20-xmlwriter.ini,
    xmlrpc_error_number => 0 => 0
    xmlrpc_errors => Off => Off
    libxml Version => 2.9.3
    libxml
    Simplexml support => enabled
    xml
    libxml2 Version => 2.9.3
    xmlreader
    xmlwriter
    libxslt compiled against libxml Version => 2.9.3

    fivestarg

    (@fivestarg)

    the extension is enabled (extension=xmlwriter.so)

    I have full control. It is on a VPS with root access

    I just cant understand what dependencies I could be missing

    • This reply was modified 8 months ago by  fivestarg.
    • This reply was modified 8 months ago by  fivestarg.
    fivestarg

    (@fivestarg)

    I figured it out. I had to also install php-curl

    then after a reboot the plugin activated successfully!

    Thanks for the help though

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Help, Braintree requires xmlwriter error’ is closed to new replies.