Support » Plugins » Help!, Bloodthirsty Penguins Want to Buy My Car!

  • I have been trying for the better part of a day to get a response, any response, to an issue I am having with the woo commerce plugin. I have failed miserably. I have determined that I am a complete failure at getting a response to a WordPress forum question, or maybe I’m a complete failure at writing a WordPress question, but in either case, I thought I’d try a different approach, starting with the Topic Title, so if you don’t want to see me attempt to work my way down the list, please, please, please throw me a bone, and either say, something like,”Tom, I think I can help,” or maybe, “Tom, you make me physically ill”, or “Tom, here is a link to so and so, they can help”, or ” Tom, penguins only like 4-door Buick’s, etc etc etc”.
    I am going to just paste the inquiry I sent to Woo-commerce, (which has also garnered no response as of yet,) and hope someone ’round here has something, anything that could be of benefit to my quest, so here goes:
    I have an issue with my checkout-pay page. When the “Place Order” button is clicked, the user is supposed to be redirected to the paypal site, however, no redirection occurs, and code appears on the page, starting with, “{“result”:”success”,”redirect”:”https:\/\/\/webscr?cmd=_cart&business” and so on.
    This text actually shows up on the checkout page, in lieu of being redirected to paypal. I have tried deactivating and reactivating my plugins, one by one, thinking maybe there was a conflict, with no success. On my locally hosted test site, the redirection occurs with no problem, but on the live site it’s a different story.
    I tried downloading some of your free themes, thinking, if it was a theme issue, I could purchase a theme, and get access to Woo customer service, killing 2 birds with 1 stone, but no dice, I had the same issue in the live demo. So, here I am pushing the red Panic Button, because as of right now, my humble website has no way to take payments, which is a problem. I would appreciate a response, and will gladly give you any additional information you might need to resolve this issue, and possibly become a paying customer in the very near future.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Heya Tom,

    Nice headline… 🙂

    I had a look at the site, and I’m not certain, but if its working on your local environment, but not on your live site, my guess would be it’s a mime/type issue.

    I’m not familiar with the woocommerce codebase, so I’m afraid I can’t be more help other than to say, perhaps the server is misinterpreting the response as text because it doesn’t have a mime type installed to understand JSON. You may want to ask your host if the server supports JSON as a mime type. If not, you may have to find the php ajax handler function for the place_order call (that’s the javascript event triggered by the place order button) and add a line like this that explicitly tells the browser it’s getting a json response…

    <?php header('Content-type: application/json'); ?>

    I’m not sure if this IS indeed the problem, but at a 2-min inspection, that’d be my first guess. Hope this helps at least point you in the right direction!



    Thanks so very much for your response. I’m looking into your suggestions, and I’ll let you know what turns up. No matter what the issue turns out to be, I now have a starting point!
    Many thanks for your 2 minutes,


    I finally got my issue resolved. The problem ended up being a conflict with Attracta, which is an SEO extension activated in my host C-Panel. I didn’t even realize I had activated it, and it doesn’t show up anywhere in the WP dashboard. Attracta then inserts itself in the code of my checkout page, and breaks the Paypal function. The only way to deactivate it (the only way Attracta’s site says anyway), is to contact their customer service (which isn’t open at night or on Sundays), and they send you instructions telling you to go into your webroot hidden files, public_html folder and delete the “.fastinclude” file. Once I did this, the problem was solved. Hope that too, might help somebody else as frustrated as I was. Once again, I thank you for taking the time to respond Greg.


    Oh man, Tom. That is a pretty unique case there. Man… Your prob was def a real head-scratcher.

    I have 1 or 2 sites on hostgator that have Attracta activated. Gonna delete that fastinclude file on each of them before they can cause me any problems too! So far no problems though, but then the sites are just straight up blogs.

    Glad you got your problem fixed


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Help!, Bloodthirsty Penguins Want to Buy My Car!’ is closed to new replies.