Support » Fixing WordPress » Help! Blog no longer loads!

  • Resolved reasontoparty


    I was having issues with getting errors when publishing new posts and was told to reinstall the wp-admin and wp-include folders via FTP from a fresh download of 2.9.2. I did this and now my blog wont load and I can no longer log in to my admin.

    The error I get when trying to load my blog is: Fatal error: Cannot redeclare is_admin() (previously declared in /home/content/r/e/a/reasontoparty/html/blog/wp-settings.php:321) in /home/content/r/e/a/reasontoparty/html/blog/wp-includes/query.php on line 99

    What can I do to fix this asap and get my blog back up and running? Sorry to sound so desperate, but this blog has been running for over three years with so much info and too many visitors, I am desperate 🙂

    Thank you!!!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Samuel B


    it looks like all the files didn’t get uploaded
    do it again – won’t hurt anything



    Thank you for your quick reply. I did download again and reupload the wp-admin and wp-includes folder again. now, I get this error:

    Fatal error: Call to undefined function: require_if_theme_supports() in /home/content/r/e/a/reasontoparty/html/blog/wp-settings.php on line 720

    If I remove that line (720), it says I need to upgrade, gives me a parse error then goes to the login page. When I try to log in, nothing happens, it goes back to the log screen again.

    If I try to open my blog itself (and not the admin panel) after removing line 720, I get this error:
    Fatal error: Call to undefined function: get_post_types() in /home/content/r/e/a/reasontoparty/html/blog/wp-includes/query.php on line 2051

    Should I try it one more time? Is it possible for me to go back to 2.8.6? That was what I had before the automatic upgrade starting causing all these problems.

    Thank you again!!

    Samuel B


    fix the file back and go to



    Samboll, you are being so helpful, thank you.
    I tried to run and get the original error again:

    Fatal error: Cannot redeclare is_admin() (previously declared in /home/content/r/e/a/reasontoparty/html/blog/wp-settings.php:321) in /home/content/r/e/a/reasontoparty/html/blog/wp-includes/query.php on line 99

    I am so frustrated but cannot tell you how much I appreciate your taking your time to help me!



    Sorry to keep posting, but now I am getting another error.
    I cleared my cache and cookies and tried to run upgrade again. This time I got a message stating that no upgrade was required. Click to Continue, but when I click to continue I now get this error in Firefox:

    The page isn’t redirecting properly
    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
    * This problem can sometimes be caused by disabling or refusing to accept cookies.

    In Internet Explorer 8 I just get an error: Internet Explorer cannot display the webpage

    Again, is it possible to download an older version and try that? If so, should I just not overwrite my content folder, and wp-config.php file but overwrite everything else?

    Thank you!!



    Forum Volunteer

    Hi there!

    Clear cookies for your website and if possible, clear the cache related to that website as well.

    I recently changed something in my own Admin panel and then my site started doing this weird redirect loop of some sort (it was on my browser end, it seems) and clearing cookies and cache fixed the problem for me.

    Give it a shot and let us know.



    Thank you, EMG. I did clear my cookies and cache in both IE and Firefox, still no help 🙁
    Again, I can get to the login screen for wp-admin, but it doesn’t do anything, just goes back there without any error messages. But, trying to bring up my blog now gives me the Firefox and/or IE error listed above.

    I am opening to any/all other suggestions. Thanks for your help!



    Also, another piece of info. Its not my computer or browser. I can log on to my other blogs, just not this one (that I recently upgraded, then started having trouble).

    Thanks again! 🙂



    Also tried: removed wp-admin and wp-content completely. Uploaded new fresh folders from wordpress download. Still nothing. Then removed config.php file and tried to let it recreate but I get cannot connect errors (file info is correct). Same issue as above.

    Any other suggestions?




    Got it fixed on my own! 🙂
    After 6+ straight hours of pulling out my hair, and trying everything under the sun… I deleted my .htaccess file and now I am back in!!

    I still need this file, so I am now off to try to fix that file.

    Thank you both so very much for your help!

    I am having this problem as well. But I am too scared to just start removing files.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Help! Blog no longer loads!’ is closed to new replies.