WordPress.org

Forums

Help! BadWare on my site (7 posts)

  1. lubvug
    Member
    Posted 2 years ago #

    Hi,

    Let me start by saying that this whole thing is 100% new to me. I am going to try my hardest not to confuse anyone, if you can help do the same.

    Recently I got an e-mail from Go Daddy (who I host through) stating there was badware on my site. I logged into my site and updated my plug-ins and it seemed to be working perfectly fine.

    Now, when I go to my WP log in page I get this error:
    Parse error: syntax error, unexpected T_VARIABLE in /home/content/85/9076885/html/wp-includes/functions.php on line 191

    I cannot even log into the page to fix whatever is wrong. Does ANYONE know how to access the site and still get in and make edits and how I can remove the message?

    My website is: http://thehatchlife.com

  2. AK Ted
    Member
    Posted 2 years ago #

    Download a copy of WordPress to your computer and unzip it somewhere.

    Log in to your GoDaddy hosting account. Click on the appropriate Hosting Account. On the '''Hosting''' tab, click '''FTP File Manager''' in the '''Tools''' section.

    Navigate to [your_wordpress_install]/wp-includes/. Find functions.php (probably on page 3 in the upper-right area), right-click on it and rename to functions.old.php or whatever you want.

    Now, click Upload file, Browse, and select functions.php from [your downloaded WordPress]/wp-includes/.

    Hopefully you can now access your site. But, it sounds like you have to find any malware on your site and remove it. That's beyond my abilities, so hopefully someone else will come along to help you with that part of your problem.

  3. esmi
    Forum Moderator
    Posted 2 years ago #

  4. lubvug
    Member
    Posted 2 years ago #

    Thank you AK Ted. I did that and now I get the following error:

    Warning: require(/home/content/85/9076885/html/wp-includes/pomo/mo.php) [function.require]: failed to open stream: No such file or directory in /home/content/85/9076885/html/wp-settings.php on line 86

    Fatal error: require() [function.require]: Failed opening required '/home/content/85/9076885/html/wp-includes/pomo/mo.php' (include_path='.:/usr/local/php5/lib/php') in /home/content/85/9076885/html/wp-settings.php on line 86

  5. AK Ted
    Member
    Posted 2 years ago #

    Please replace your paths listed with /home/content/XX/XXXXXXXX/..., the second numbers (8 digits) are unique to your hosting account. I don't know if there's a security risk or not, but better safe than sorry.

    I'm not sure, but you could try uploading that file as well. But, since you were warned by your host that your site was infected, you should really follow those links that Esmi listed above.

  6. lubvug
    Member
    Posted 2 years ago #

    Sorry, probably a dumb question. But I do not see any paths with home/content. Where should I be looking in the FTP?

  7. AK Ted
    Member
    Posted 2 years ago #

    The home/content/xx/xxxxxxxx/ is the private part of your site. html/ is your public root, equivalent to www.your-domain.com/. So ignore everything before (and including) html/.

Topic Closed

This topic has been closed to new replies.

About this Topic