[resolved] Help! Altering php.ini file caused Internal Server Error; now I can't login. (6 posts)

  1. Jana
    Posted 2 years ago #

    I'm working on a test site, on which I did a fresh install with the twenty thirteen theme. I have not installed any plug-ins.

    The first thing I did was try to install the paid theme. (Avada) I kept running into a file upload limit, so I followed option 1 on this page, which is to add three lines of code to the functions.php file.

    I did this through Appearance > Editor in the back end. But as soon as I clicked to make the change active, I got a 500 Internal Server Error message. Tried to get to a few other pages, kept getting that error. Logged out; now I can't even log back in. I get the log-in screen, but when I click log in, I get the same error page. So any solution that involves the back end won't work.

    I went in through ftp (via Filezilla) and looked for the functions.php file in twenty thirteen, but I'm not finding it.

    I don't currently have access to the host -- and would rather not bother the client with that if I can find another way to fix it.



  2. esmi
    Forum Moderator
    Posted 2 years ago #

    You need to speak to your hosts about this.

  3. Jana
    Posted 2 years ago #

    esmi -- The instructions that you gave on another thread here actually solved my problem:

    Try switching to the Twenty Eleven theme by renaming your current theme's folder in wp-content/themes and adding "-old" to the end of the folder name using http://FTP...

    Or at least it got things fixed to where I can log in to the back end, which is a start.


  4. Jana
    Posted 2 years ago #

    Okay, for anyone else who experienced my problem or some part of it, here is what I did.


    1. Tried uploading Avada several different times. Every time, I got the "Are you sure you want to do this? Try again" message.
    2. Some googling revealed that the problem was with file upload limit. I followed the instructions for Option 1 on this page: http://wordimpress.com/how-to-increase-wordpress-file-upload-size-correctly/
    3. Following these instructions resulted in my site throwing a 500 Internal Server Error. I logged out, only to find that then I couldn't even log in.
    4. Much hair-pulling and teeth-gnashing.
    5. Found help in the WP forums: "Try switching to the Twenty Eleven theme by renaming your current theme's folder in wp-content/themes and adding "-old" to the end of the folder name using ftp." I was still using Twenty Thirteen up to that point. So via ftp, I renamed that folder as advised.
    6. Okay, now I can log in. Went to Appearance > Themes. Made extra sure that I am trying to upload the correct Avada file. Tried uploading again. Back to the "Are you sure you want to do this?" screen.
    7. Thinking Avada needs to lose some weight.
    9. Tried uploading Avada theme by ftp, using the instructions found here: http://www.youtube.com/watch?v=WQ5IuHuDaNQ
    10. STILL NOT WORKING!!! It doesn't show up in the "Available Themes."
    11. Wait... did I really upload the right unzipped file? Double check...
    12. Um. No, I didn't. :/ Ftp the right file: SUCCESS!!!

  5. I'm going to take a wild guess here but It really seems like you are having a problem with that Avada theme.

    Did you considered asking for support from the theme author you purchased that theme from...?


  6. Jana
    Posted 2 years ago #

    Well, this situation would apply to anyone who was trying to upload a file that was too large and messed with the functions.php to fix it.

    But I did actually resolve the problem: see step 12.

Topic Closed

This topic has been closed to new replies.

About this Topic