Support » Fixing WordPress » Help! – Allowed memory size error

  • Resolved neuville


    it’s some day’s I get this error when editing posts and posting new stuff:

    Fatal error: Allowed memory size of 12582912 bytes exhausted (tried to allocate 575587 bytes) in /wordpress/wp-includes/functions.php on line 373

    Fatal error: Allowed memory size of 12582912 bytes exhausted (tried to allocate 555448 bytes) in /wordpress/wp-includes/cache.php on line 306

    It has started since I’ve planned about 20 – 30 posts as “future posts”. I’ve checked both the files, but I’ve found no strings speaking of memory.

    I’ve no images plugin installed on the weblog.

    I use an external DB hosted at my hosting company.

    The weblog address is

    Please, help me to solve this issue! Thank you in advance 🙂

Viewing 15 replies - 1 through 15 (of 15 total)
  • You need to increase your per-php-process memory limit. It’s obviously set to 12MB, I’d probably recommend you try it in 4MB stages (16MB, 20MB, 24MB, 28MB, 32MB).

    There’s been lots of discussions of the memory overhead issues, yet to see a response with any ‘answers’ of how to reduce the footprint. Easier to increase the PHP process size. 😉

    Hello David,
    thank you for your help.
    where can I change the parameter? I’ve a shared hosting, and I cannot find how to change it from the control panel.

    Ask your host to increase it and add a big “please”.

    Hello lhk,
    thank you for your reply. I’ll do this!


    Hey guys, I contacted them… since they suck, they do not want to do the job…
    is anything else I can do to solve this?

    Thank you

    I don’t know of anything offhand — doesn’t mean it doesn’t exist.

    Very few credible hosts set it to 8M, or won’t increase it. The hosts that don’t care are usually free, or very cheap. 😉

    Definitely turn OFF the internal wp cache mechanism. That can’t be helping. If you search around, there’s a DEFINE statement that you can add to your wp-config.php to disable the caching. It’s now defaulting off, never should have been on — it’s only for high-end systems, and potentially still customized versions at that.

    Also watch any custom plugin queries that might be retrieving large tablesets. That’s where a lot of the memory goes.


    Check to see if you can run a per folder (or better, domain root) php.ini file. If that’s a go, you can increase the limit in the file. I’ll have to dig around to find out what the line is to input, but find out first if you can do that – some hosts don’t allow it.

    The cache line for wp-config.php:

    define(‘DISABLE_CACHE’, true);

    Hey guys, thank you.

    The host is really cheap, but is the better I can buy 🙂

    I’ll disable cache and check if it work.

    thanks again

    still not working… it just happens when posting / editing new posts, while the weblog looks working good…

    Ahh. That’s WAAAAY different. The admin interface is doing tons of stuff behind the scenes, could easily not be optimized for memory.

    This is what I would do if I had such a problem. First, I’d try turning off the wysiwyg editor. Just on a lark. Second, I’d look into whether you can turn off the post-preview at the bottom of the page (I don’t know whether you can or not). Third, I’d look into whether the ‘simple post screen’ is still available — that is, the non wizzy ajax version, circa WP1.5.

    Those could help a lot.

    Additionally, could also depend on things like how many categories you have, how many users, etc. Anything that the post screen might grab in a massive query. Just a thought.

    I’ve been assuming you mean trying to go into the post or edit panel it dies — or did you mean when SAVING from either one?

    Hello David,
    it happens just when saving. The posts are saved and published, but instead of getting the new post panel i get the error on the blank page.

    The weblog is correctly updated, btw.

    I’ve not the wysiwyg (but just the html, since the wysiwyg is not precise on formatting), but I don’t know hot to disable teh preview and to get the simple post screen.

    I’ve about 25 categories in the panle, but I was thinking it could be a problem of tags: I’ve UTW installed with tons of tags…

    Hi guys,
    the thing seems resolved. I’ve progressively disabled all the plugins and tested: the problem was with the Ultimate Tag Warrior. I do not know what kind of problem, but it is working good now without the plugin.

    Thank you for your time and support 🙂

    I am getting this same error but its on my Options page of the admin section, I have deactivated all plug-ins, increase per-php-process to 32M, inserted define(‘DISABLE_CACHE’, true);, and the problem is still there. This problem only started happening after I pasted 90 pages. If there a limit of how many pages that WordPress can handle.

    I too am getting this error ad different places. I am getting it when trying to upload a picture (it uploads the picture and then crashes), when trying to view pictures that have already been uploaded, etc. The error is:

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 7 bytes) in /wp-includes/formatting.php on line 31

    Guys, I think I just solved the problem! Edit your php.ini file and make sure that you have

    output_buffering = Off

    Hope this helps!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Help! – Allowed memory size error’ is closed to new replies.