Support » Fixing WordPress » Help! 404 error on all pages!

  • I just upgraded 4 blogs to 2.5 – and only the homepage works on each – clicking on category/page/post links just results in a 404 error!

    Help – how do I fix this?

    I just published a new post and that one doesn’t exist either…

Viewing 12 replies - 1 through 12 (of 12 total)
  • Update:

    Ok – only 2 blogs are affected so I’m assuming it’s a plugin problem – I’m going to switch them all off and see what happens

    Moderator Dion Hulse


    Lead Developer

    First up i’d reset the Permalink structures to the detault (?p=123) non-pretty urls.
    If that works, Then i’d try the permalink structure you had before.

    If that doesnt work, I’d suggest changing to the default theme, And deactivating all plugins.

    If that works, re-enable your chosen theme, verify it works, and reactivate the plugins one by one to find the culprit.


    Still no content – it’s as if it’s all been deleted even though it’s in the dashboard – I’ve tried re-saving it but no use

    dd32 – thank you so much! I switched the paermalinks back to default and now the pages work!

    Now I just have to work out how to upgrade my site back to 2.5… I managed to roll it back but Dreamhost thinks it’s at 2.5 for the one-click install *lol*

    For me, pages only work with default permalink structure. I use custom permalink structure /index.php/%postname%/ and it gives 404 error for every page.

    This happens in 5 different blogs I maintain.

    I have the same problem with the same permalink structure as aarnet above, /index.php/%postname%/. Using the default permalinkstructure (?p=123) I can view pages, but when I use the structure (/index.php/%postname%/) I’ve used this last year, pages gives a 404. It works just fine for posts though.

    I’ve tried deactivating all plugins, switching themes, and updating the permalink structure, but the problem is still there.

    Same here. 4 Blogs, all pages turned to 404er whith permalink “index.php/%postname%/”, works fine with standard permalinks.

    Looks like a bug to me.

    2.5 looks great and I salute the developers, thanks for a great job. You guys rock!

    However, I’ll have to roll back to my previous version until I can figure out this page-permalink issue. I don’t know whether it’s a bug or not, but I need those pages back up. I’ll set up a test site and run 2.5 there until the solution is found.

    Mama, I’m comming home 🙂

    For those of you using XAMPP (or some variant) remember you have to enable mod_rewrite in apache itself or you won’t be able to have permalinks the way you want them to. Look here to see how to enable it.

    Same goes if you are rolling your own LAMP stack.

    My problem is solved as of 2.5.1. Thanks a lot for the good work ryan and dlo!

    I just upgraded 9 blogs to 2.5 – and then to 2.5.1 -only the homepage works on each – clicking on category/page/post links/and comments just results in a 404 error!

    I have already tried to change the permalinks to default with no results. still no go except main page.

    It now works after I deactivated the ‘customize permalink’ plugin and switched to default setting on the permalinks and reset by changing the theme to ‘default’ and then back again to my current theme. Now all the navigation works on my site.

    However, all the hundreds of links to my past articles and pages from other blogs and sites will now be broken. Nearly half of my traffic comes from past links.

    Any fix or plugin out there to do a ‘date and name’ permalink with 2.5.1?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Help! 404 error on all pages!’ is closed to new replies.