Support » Fixing WordPress » Help. 11 days trying to move WP site from Bluehost to iPage & it's still not ok

  • Hoping someone might be able to make some suggestions. I’m trying to move a school website from one host to iPage and things are not going very well.

    For a start, I can’t get a trace route from Thailand to the default IP to complete. A ticket has been lodged with the local ISP who are doing their best to ignore me as much as possible I think. These are the last two hops.

    18 (  297.195 ms (  289.249 ms (  299.195 ms
    19 (  296.528 ms !X (  297.537 ms !X (  289.045 ms !X

    If anyone else is able to run a traceroute or ping (100% packet loss from there) on I would appreciate it.

    The ping test just repeats:

    PING ( 56 data bytes
    36 bytes from ( Communication prohibited by filter
    Vr HL TOS  Len   ID Flg  off TTL Pro  cks      Src      Dst
     4  5  00 5400 63c4   0 0000  2e  01 9146

    Notwithstanding this I can log in to the iPage control panel, file manager and MYSQL.

    The existing website also has a SMF Forum, but I am ignoring that at this stage and not importing the database fields for it as they import with a lot of errors, despite a Check table on the current host showing they are ok. It’s something I’ll discuss on the SMF Forum.

    What I have done is:

    Downloaded the existing site in its entirety by FTP to my computer.

    I’ve created a sub-directory titled /mywebsite

    I’ve FTP’d up the downloaded site to the /mywebsite sub directory.

    In the root is a .htaccess file configured as:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /mysebsite/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /mywebsite/index.php [L]

    and a index.php with the values

    /** Loads the WordPress Environment and Template */

    In the /mywebsite subdirectory the .htaccess file is

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /mysebsite/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /mywebsite/index.php [L]

    # END WordPress`

    and a standard index.php

    /** Loads the WordPress Environment and Template */

    In the wp-config file of /mywebsite I’ve changed the database name, username, and password to reflect the new MYSQL settings, and the DB host name from “localhost” to cater for the way iPage defines the DBHost.

    The school has both a .com and a .net variant of its domain name. The .com variant is still pointed to the old host, while the .net is now pointed to iPage and routed to point to the /mywebsite/ subdirectory

    I’ve exported only the WordPress files from the existing site database and imported them into a new database on iPage.

    I’ve changed the DB tables values for site URL and Home to:

    I’ve updated the plugins (and also tried disabling all of them and reenabling the absolutely necessary ones) and I’ve ran a repair on the DB tables to clear any overhead after making any changes that produce overhead and ran a Check Table and the only error is:

    More than one INDEX key was created for column post_id

    This is the GD Star Rating plugin and not an issue. In any event it is disabled for testing.

    If I enter I can access the dashboard fine.

    I’ve updated the permalinks and tried without and with the trailing slash here:


    I’ve even checked the wp-includes version.php against the wp-options DB table to ensure the DB versions are the same.

    And I’ve done an automatic reinstall of WP 3.4.2 in addition to uploading manually and overwriting the wp-admin and wp-includes folders.

    All of the pages, media files, comments etc seem to have imported fine, but I can not see them in the dashboard panels. The file count at the top says they are there, but I can’t see the individual posts and pages without turning off Event Calendar plugin by Alex Tingle.

    Whether the Event Calendar Widget is active or inactive has no effect on the dashboard posts and pages panels.

    If I attempt to access the site using the I get a white page on screen.

    If I add /wp-admin I am on the sign-in page

    If I add the full name of the site I get a 404, but at least with a part of the template showing. The .net version on iPage shows unformatted menus on the right side (English & Thai), which if clicked on still returns a 404 for that page, but restores the buttons that the menu text should sit in.

    After 11 days of trying to get this simple move to happen I’m at my whits end. Any logical suggestions anyone?

    The site should look like this

    Instead it looks like this

    PS. If you got this far without dying of old age or boredom thank you. Sorry this is so long but anything less would only describe part of the problem.

Viewing 4 replies - 1 through 4 (of 4 total)
  • for moving a wordpress website from one host to other you can refer this webpage.

    i hope this may help you

    i have moved my website to other host and shared this with others

    @ Santoshi, Thanks, but your steps assume to much, such as the naming protocol for both hosts’ MYSQL being the same for a start.

    On Bluehost the DB Host will be “localhost’, whereas on iPage the DB Host will be in the form

    On Bluehost the DB_Name will be in the form: ‘myhostingaccount_mydatabase’ but on iPage it will be simply ‘mydatabase’

    yes i known that because i faced similar problem as you said about hostname.
    change your hostname in config.php and also when you are created database create which same name and password as previous one. I mention this in my post
    Also note down the database names and passwords it will required for creating new databases on new web server.

    [Content moderated. Do not use these forums to solicit work]

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Help. 11 days trying to move WP site from Bluehost to iPage & it's still not ok’ is closed to new replies.