WordPress.org

Forums

Help (5 posts)

  1. Anonymous
    Unregistered
    Posted 11 years ago #

    as you can see here: http://trampled-over.net/index.php if you look the categories for each post is shown:
    5/7/2004
    Word Press(
    Site
    )
    When its suppose to show like this:
    5/7/2004
    Word Press (Site)
    Any idea how/where can I fix this?

  2. Ozh
    Member
    Posted 11 years ago #

    The generated html is :
    <h3 class="storytitle" id="post-120">Nuevo Layout.
    (<ul class="post-categories">

  3. Site
  4. )
    </h3>

    Basically, remove the
    • and
      • and it will be ok.

  • Matt Mullenweg
    Troublemaker
    Posted 11 years ago #

    Actually, there are two ways to approach this. You could style the list to appear inline, or you could simply make the_category not return list markup. Both are documented in the forums and the wiki.

  • NuclearMoose
    Member
    Posted 11 years ago #

    Also, I would suggest that a more informative question posted as the topic title is in a person's best interest, as well as for the future when someone is searching for an answer to a similar question.
    Craig.

  • WillM
    Member
    Posted 11 years ago #

    I would note that ozh's solution may be confusing to some people, as the li's are generated by the WordPress code itself and will not be found in the index.php markup.
    I don't think that a more informative header would have helped this person, as most of us would have thought 'oh no, not the bullet question again' and skipped it. It also wouldn't help future users that I can see, because as Matt pointed out there are quite enough instances of this question here already.

  • Topic Closed

    This topic has been closed to new replies.

    About this Topic

    Tags

    No tags yet.