Support » Plugin: podPress » hello jsut a problem with itune

  • itune cant’accept rss2 they said “no episode” do you have an idea and thank’s for all ;-))) great great

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author ntm


    If you get the message “no episode” from the iTunes Store or the iTunes client software then you should control whether there are episodes in the RSS feed of your blog or not. One other cause for such a message might be that your podcast feed is invalid. Use the this feed validator to control what is wrong with the RSS feed.
    If you have started your blog just now and you have not published an episode then the feed appears to be invalid too.

    thank’s for your answer i try my rss with feed validator it’s ok but it seem i forget to put episode inside this one how can i do it i try to find one rss editor who works with worpress but find nothing ?? yet ;-)) thank’s

    i try to open it with rss edit but i dont know the right one to open to put all itunes need about my futur podcast ;-(
    episode number etc etc… thank’s a lot

    Plugin Author ntm


    If you are using WordPress and podPress you don’t need to edit the feed with some kind of XML/feed editor.

    • Upload your media files (for instance via a FTP software)
    • insert the complete URL into the input field “Location:” of the podPress box below the post editor of WP
    • save the changes (or publish the post)

    If you do that the media files will be as a part of the posts in the RSS feed.
    You may insert further data about a media file like the duration or a an episode title. The related input fields are also in the podPress box below the post editor of WP.

    thank’s for your answer, i do like that and i can read my podcast no problems but when i try to register with itune they say my rss do not have episode in it

    here is my rss if you can have a look
    if i try
    i have nothing

    thank’s i think i will retry from the start

    but thank’s again

    Plugin Author ntm


    Thank you for posting the link to your blog!

    There are 2 issues:

    1. Your podcast feed is not activated. Open the Feed/iTunes Settings page of podPress and go to the section podPress Feeds.
    In this section you will find the settings for the feed
    The first check box is named “Activate Feed”. It needs to be checked in order to activate this feed.

    2. Your have posted your first episode only on a static page and not as a post. That is okay. But the RSS feeds of a blog contain only posts and not pages. That is why the episode is not visible in one of the RSS feeds.
    I recommend that you add your episodes to regular posts. Put these posts in a certain category e.g. “Podcasts” and create a link in the menu bar to the page which displays only posts of this category.
    For instance your blog has the category “Uncategorized”. If you click on this category name in the sidebar of your blog, you will get to the page which shows only posts of this category:
    If your create a new category you will get such page for this category too. Furthermore you may link this page in the menu bar (below the header image) by using WordPress Menus (
    This way you will get a page with a list of your podcast episodes and it is a technically better solution than adding all your episodes to a static page.

    greattttttttttttt thank’s a lot i just have to make a regular post ( i do the rest)

    great i just try with 2 episodes tomorow thank’s a lot

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘hello jsut a problem with itune’ is closed to new replies.