Support » Plugin: Advanced iFrame » Height question – Pro version

  • Resolved Squiggy45

    (@squiggy45)


    I’m using the free version and the height of the iframe is not conforming to the height of the content, which is 100%. Will the pro version fix that?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author mdempfle

    (@mdempfle)

    How is your setup?

    Are you on the same domain? Do you use the external workaround? How looks your shortcode?

    Best Michael

    The source is an html web page on the same domain. I don’t think I need the external workaround then, right? Shortcode is:

    [advanced_iframe securitykey=”a6359db81412c57c2b34b7b825dbb9d8e1e31c45″ src=”http://rezility.rocks/Assets/effect/banner.htm”]

    I’ve tried 100% for height, which of course doesn’t work. Also tried 0. Right now it’s on 600. You can see the result at http://rezility.rocks

    It’s the top banner.

    • This reply was modified 1 month, 4 weeks ago by  Squiggy45.
    • This reply was modified 1 month, 4 weeks ago by  Squiggy45.

    I’m using the free version. If I purchase the pro version will I be able to fix it?

    Plugin Author mdempfle

    (@mdempfle)

    The free version works on the same domain as well.
    Have you enabled the resize?

    “Resize iframe to content height” in the administration or onload_resize=”true” in the shortcode?

    Best, Michael

    Below is my shortcode. When I added the onload_resize=”true” it did the opposite of 100% height. It shrunk it to about 100 pixels high. I’ve taken it out. Are there any options in the paid version that might help?

    [advanced_iframe securitykey=”a6359db81412c57c2b34b7b825dbb9d8e1e31c45″ src=”http://rezility.rocks/Assets/effect/banner.htm” scrolling=”no”hide_page_until_loaded=”true”]

    Plugin Author mdempfle

    (@mdempfle)

    You have a missing space in your shortcode which make 2 attributes invalid.

    But your “problem” is different as your page is fully responsive. So the measurement will not work as I try to shrink the content to the minimal possible height. And in your case this will decrease the height too much.

    The minimal height is 1 right now. You can increase this value “resize_min_height”
    by setting this in the shortcode e.g. resize_min_height=”500″

    In your case I think a resize to a certain ratio is also a good solution:

    Like
    http://www.tinywebgallery.com/blog/advanced-iframe/advanced-iframe-pro-demo/responsive-videos

    This is a feature of the pro version.

    Best, Michael

    I tried the ratio option after purchasing. Here’s my shortcode:

    [advanced_iframe securitykey=”a6359db81412c57c2b34b7b825dbb9d8e1e31c45″ src=”http://rezility.rocks/Assets/effect/banner.htm”scrolling=”no”enable_responsive_iframe=”true”iframe_height_ratio=”0.4989″]

    It’s a bit too tall now. I divided the height by the width to get the ratio, but it’s still not really responsive. Different sizes on different monitors. Any ideas? Works perfectly outside of the iframe.

    I wonder if the menu on top is affecting the height? It seems that the height is off by about the same amount as the height of the navigation.

    • This reply was modified 1 month, 3 weeks ago by  Squiggy45.
    Plugin Author mdempfle

    (@mdempfle)

    Hi, Not sure what you mean. at http://rezility.rocks/ the height looks good to me. also if I resize the browser the banner scales how I would expect it.

    I see a vertical scrollbar which I would not expect there. But if I remove the iframe from the page it is still there. So it seems to be a problem of the theme…

    Also be aware that if you use a shortcode like above you always only overwrite settings from the administration. To make sure that only your settings in the shortcode are used add use_shortcode_attributes_only=”true” to your shortcode.

    Best, Michael

    If you compare it to the source: http://rezility.rocks/Assets/effect/banner.htm
    there is a huge difference. Source is exactly 100% height on every device/monitor. I see no vertical scrollbar in the iframe. I do see one on the far right, but that’s to be expected since there is content below the iframe.

    Plugin Author mdempfle

    (@mdempfle)

    Now I understand what you mean. You want the banner 100% height of the viewport?

    Then remove the whole ratio stuff and use e.g.

    height=”100vh-100px”

    where the 100px is for the header! The pro version does support calculations at the height. If you have different headers for different devices you then can also use the browser detection.

    Best, Michael

    Soooo close! That helped a LOT, but now I’ve got a horizontal scroll even though width is set to 100%.

    I commented on your forum. I’ll stop replying here. Thanks!

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.