Support » Plugin: Gutenberg Post Blocks » Heading Style not working – theme heading is inherited

  • Resolved chubby162

    (@chubby162)


    Hello,

    I tried to use HEADING style from this plugin, but whatever style I choose, it looks good in the wordpress editor, but when I publish my post, the heading still looks normal with my theme default style. I think it’s inherited from theme.

    How can I solve this?

    I am using OceanWP Theme.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author wpxpo

    (@wpxpo)

    Hi @chubby162,

    Thank you so much for using our post blocks plugin. I have checked this issue on my local computer using OceanWP Theme. The heading style works fine for me. See the attached screenshot https://prnt.sc/uam48z.

    Note: Could you please share your website URL. I need to check your issue. Wating for your reply.

    Hey, This is link to the post on my website where I used it and it looks different than on your screenshot.

    Plugin Author wpxpo

    (@wpxpo)

    I guess you have missed adding the typography setting. See the screenshot https://prnt.sc/uaza1a.

    Note: Hope your problem will be solved. Waiting for your reply.

    Still not working – any changes that I make in typography settings don’t affect the heading in the post (even when I change the color of the text – it still doesn’t work). It changes heading in the editor, but not in published or previewed post. I think that plugin works fine, but my theme’s CSS cause the problem.

    I could give you access to my website if this would help. Thank you for your time.

    I think I solve the issue, but I’m not sure what caused the problem.

    In my post, when I created a column and put heading inside the column – it didn’t work.

    It started to work, when I created another heading outside the column. – After that both headins worked – the one inside the column and the one outside.

    If you want to check if that’s a problem with a plugin, you could make a post and create it like this:

    GROUP
    >COLUMN
    >>HEADING

    On my website this set up makes the heading not working.
    When I put another heading outside the group and the column, it works fine.

    Plugin Author wpxpo

    (@wpxpo)

    Hi @chubby162,

    I am really happy to know that you got the solution. Just now I have checked both the outside and inside columns. It works fine for me. As you mention that in your system heading style works for the outside columns. So, you can use it outside the column.

    If you are satisfied with our support then give us a five-star review in the WordPress directory. As a new plugin developer, it helps us a lot.

    Have a nice day.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.