Support » Theme: Neve » Heading H1 stays over menu

Viewing 7 replies - 1 through 7 (of 7 total)
  • luciamarinescu

    (@luciamarinescu)

    Hi @vbachem!

    Thanks for choosing Neve!

    It looks like the submenu color is set to transparent, this is why the headline is also visible when the submenu is opened. Please insert the code below in the Additional CSS section within the Customizer. It will make the submenu background color white so the text behind it won’t be visible anymore.

    .sub-menu {
        background-color: white !important;
    }

    Let me know how this worked!

    Have a nice day!

    Thread Starter Valentin

    (@vbachem)

    Yes it is working.
    Perfect, thank you.

    Are you going to fix this in the theme with the next update?

    luciamarinescu

    (@luciamarinescu)

    Great, I’m glad it is properly displayed now!

    This isn’t an issue with the theme to be fixed in the future. I created a submenu on a test page and it is displayed as expected – screenshot, so it doesn’t seem to be a problem with the theme.

    Thread Starter Valentin

    (@vbachem)

    I’ve checked if it is a plugin that is responsible for that problem.
    It isn’t. The problem is there, even if I deactivate all plugins and clear the browsercache.

    Is it the free Version, you’ve installed on your test site?

    • This reply was modified 4 months ago by Valentin.
    luciamarinescu

    (@luciamarinescu)

    Hi @vbachem,

    This behavior is caused by a combination of settings rather than an issue with the theme. As far as I tested with the free version of Neve, it happens when the background color of the header row, where the menu is added, is set to be transparent, which isn’t the default setting applied by the theme, and the page template is Default. The background color of the submenu inherits the background color of the header row where the menu is added, therefore, this incompatibility.

    There are two solutions for it, one is to change the background color of the header row, and the other one is to change the submenu background with the custom CSS code provided above.

    Have a good day!

    Thread Starter Valentin

    (@vbachem)

    The Background was set to #ffffff.
    I switched to another color and than back to white.
    Then it was no more transparent.
    Crazy problem.

    Thanks for your help!

    luciamarinescu

    (@luciamarinescu)

    I’m glad to hear it’s solved now!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.