Support » Plugins and Hacks » [Resolved] Headers already sent error with Mylinks 4.6

[Resolved] Headers already sent error with Mylinks 4.6

  • Hi,

    Unfortunately the last upgrade to Mylinks 4.6 broke my site for all URLs contianing a ? (probably similar problem as reported by mlauten in another topic).

    All URLs containing “?” (e.g. logout) generate a dozen of errors like :

    Warning: Cannot modify header information – headers already sent by (output started at /(…)/wp-content/plugins/mylinks2/mylinks.php:1) in /(…)/wp-login.php on line 368

    I tried to open mylinks.php and options.php and save it with UTF-8 without BOM encoding (I remembered it helped with another similar error with another plugin), without success.

    Any idea?

    Test URL if you want to reproduce the error: -www.around-annapurna.com/wp-login.php?action=logout


Viewing 5 replies - 1 through 5 (of 5 total)
  • I think I solved it, simply by removing the two blank lines at the end of mylinks.php 🙂

    I do not get the error anymore. If the plugin author reads this, could you please confirm that these two blank lines should be removed?



    That fix worked for me also. It was scary initially as when I saved the edited file I got just a white page with three error reports instead of two, but I clicked back, then refreshed the editor page and all was well. Thanks so much. Good eye.

    @lecyril – Thank you for that suggestion, that worked for me, too, but the author should still fix this. I was not able to log into my admin at first. I removed the plugin folder using FTP, and then reinstalled the plugin, but I got the same error.

    This should still be fixed and put into a new version. I have two other sites that use this plugin, and I think I will wait until it’s fixed.

    I have had a few bad experiences with plugin “upgrades” to give me a stomach ache for one day!


    lauratasita, you are right when you say in your other thread that maybe this one should not be tagged as “resolved”, since what I found is merely a workaround waiting for the author to be definitely fixed!

    Just to be clear, I decided it to tag it as “resolved” so that other users could know there is a temporary solution out there …

    Anyway, glad this helped!


    Plugin Author 2020media


    We have fixed this problem.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Headers already sent error with Mylinks 4.6’ is closed to new replies.