Copygram widget
headers already sent error (3 posts)

  1. gstrambi
    Posted 3 years ago #

    i was creating a blog for a customer of mine, all was perfectly working from january, yesterday my customer changed his instagram username and today the blog gives this error:

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/23/10324823/html/wp-content/plugins/copygram-widget/copygram-widget.php:757) in ..../index.php on line 18

    i've changed all params in copygram and widget, if i go to copygram site all is working, the new username is correctly displayed and all pics are listed

    The very strange thing is that if i reach directly a page of the blog, for ex. index.php?p=xxx the copygram widget is perfect, and i have no errors, but if i reach the home page (that starts with the latest post, the one that i see correctly if directly reached with ?p=xxx) i have only the error and nothing is displayed

    Please help me, thanks

    p.s. sorry for my bad english!


  2. gstrambi
    Posted 3 years ago #

    i forgot to say that i've tried to deactivate, and reactivate the plugin, remove and reinstall...when i reactivate it a message say :"The plugin generated 1 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin."

  3. gstrambi
    Posted 3 years ago #

    i solved inserting "ob_start()" on index.php first line, but the problem is still there. If anyone has an explaination i'll be very grateful


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Copygram widget
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.