Support » Fixing WordPress » Header Trouble – Space above Title

  • Resolved Harvey


    Hello everyone,

    I’m battling the header in a new WP installation.

    I did not want the title of the blog to appear as I had it set in ‘General Options’ in the WordPress admin panel, so I went into the header.php for my theme and added my own <title> tag.

    However, I still get a strange space above my site where the wordpress provided title used to be. You can see what I mean here…

    The code from my header is below. Any help appreciated!

    <head profile="">
    <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" /> 
    <!-- <title><?php bloginfo('name'); ?> <?php if ( is_single() ) { ?> &raquo; Blog Archive <?php } ?> <?php wp_title(); ?></title> -->
    <title> - Great gadgets from around the world</title>
Viewing 7 replies - 1 through 7 (of 7 total)
  • Just out of curiosity, why don’t you just add your custom blog title ( – Great gadgets from around the world) under the blog name field under the WordPress options? Doing so this way will probably say you alot of time and headaches.

    The issue is, if I have it like that (you can see it now), the name is displayed in text over the top of the website. I would rather this not be shown.

    Can I remove or comment out the code that is displaying this? Where is it located within the theme?

    Help appreciated!

    When you comment like this <!-- <?php rest of the code ?> --> the <?php ?> is still parsed, so either you remove it or you break it like so < ? php rest of the code ? >
    But the easier way to hide the title is simply by adding display:none; to the css, in your case:

    	font-family: Verdana, Arial, Helvetica, sans-serif;

    Thanks for that themystical! One follow up question.

    Now the strange mark is gone, however the large gap of nothingness is still at the top. Is there anyway I could remove this gap so that the title image of my page is more to the top of the screen?

    I tried fiddling with padding-top:30px in the CSS, but it doesn’t seem to affect anything. That was just a guess though… I don’t really know what I’m doing!

    Thanks again~





    adjust that.

    To completely remove the top part…:

    1. header.php line 29 remove or comment out
    <div id="header_top"> and don’t forget the closing tag
    at line 33 </div>

    2. style.css adjust the height in #header from 298px to 194px. you can also remove #header_top since is not used anymore.

    Awesome… Thanks everyone!

    Wow I so do not know CSS…

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Header Trouble – Space above Title’ is closed to new replies.