WordPress.org

Forums

header text broken, theme font over-ridden (9 posts)

  1. Jym Tarrant
    Member
    Posted 4 years ago #

    When I use header text in my posts, it just shows up as bold text, though if i underline it, the line appears lower as it would if the header text was a larger size as per normal.

    Also, the font setting for my blog is being over-ridden by whatever font is pasted into the post.

    I am using the visual editor, as I have done for some time. I haven't had this problem, and have changed no settings. I have tried de-activating all plugins, but no result

    My blog is at http://jymtarrant.com

    Please help! Thanks

  2. doc4
    Member
    Posted 4 years ago #

    Jym Tarrant,

    I'm currently seeing a bottom border via CSS on the titles not an underline, unless we are talking about something else?

  3. Jym Tarrant
    Member
    Posted 4 years ago #

    I took the underline off the header text, because I wanted to publish my post anyway.

    I don't mean the title text for the post, just the Bold in post headers. For example, the heading in the first line of the post on my front page "Ultimate Success Formula" is set to be 'Heading 1' which should be very LARGE text! As you can see, it's the same size as the 'paragraph' text

    Cheers

  4. dHeinemann
    Member
    Posted 4 years ago #

    I just started experiencing this problem. I've tested it in both Chrome and Safari on OS X and Chrome and Firefox on Windows 7. I've tried disabling all plugins, changing the theme, reinstalling WordPress (via the Update function) to no avail.

    My Heading 1 has started appearing bold (ie, as if it were only bold text), as described above. This came out of nowhere, for no apparent reason. What's strange is that this problem only occurs in new posts that I write, or old ones that I update. For example, compare http://www.dheinemann.com/2010/fortnightly-update-28-december-2010/ with http://www.dheinemann.com/2011/fortnightly-update-10-january-2011/.

    Looking at the HTML source of these posts, I can see that the newer post contains clean H1 tags, whereas the older post has additional styling applied to it.

    Compare:
    <h1>Last fortnight’s goals</h1>
    with
    <h2 style="padding-top: 15px; padding-right: 0px; padding-bottom: 5px; padding-left: 0px; outline-width: 0px; outline-style: initial; outline-color: initial; font-size: 1.3em; vertical-align: baseline; background-image: initial; background-attachment: initial; background-origin: initial; background-clip: initial; background-color: transparent; background-position: initial initial; background-repeat: initial initial; margin: 0px; border: 0px initial initial;">Last fortnight’s goal</h2>

    The last time I installed a WP update was when 3.0.4 came out, and I haven't installed any new plugins or themes since long before that. I don't understand why it has suddenly changed.

    Does anybody know what's going on? Jym, were you able to fix this?

  5. esmi
    Forum Moderator
    Posted 4 years ago #

    My guess is that you have some unclosed </strong> tags in a previous post.

  6. dHeinemann
    Member
    Posted 4 years ago #

    Thanks for the quick response. I just took a quick look at my recent posts and couldn't find any. But if this were the case, then wouldn't this issue only occur on the main page (where multiple posts are displayed)? I'm having this problem even when viewing a single post or a page, such as http://www.dheinemann.com/useful-software/

  7. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Ten theme to rule out any theme-specific problems?

  8. dHeinemann
    Member
    Posted 4 years ago #

    I had tried deactivating all plugins and swapping the theme before, but I didn't actually try Twenty Ten. Now that I did do that, it looks like it's fixed.

    Upon testing the other themes, I found that the issue only occurs in two - the one I usually use, and the one that I happened to switch to the first time I tested another theme. They're actually both made by the same team, but these themes haven't been updated by them or myself any time recently, so it seems strange that they're suddenly having issues.

    Do you have any other ideas? At this point it sounds like I must have done something stupid to the themes and forgotten about it, so I'll try reinstalling the original versions of those themes tomorrow. If that doesn't help, there may be an issue with the themes themselves.

    Cheers for the advice.

  9. esmi
    Forum Moderator
    Posted 4 years ago #

    Both themes may simply be incompatible with your version of WordPress.

Topic Closed

This topic has been closed to new replies.

About this Topic