WordPress.org

Support

Support » Themes and Templates » [Resolved] Header shows twice?

[Resolved] Header shows twice?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator Michael

    @alchymyth

    Forum Moderator

    no problem visible in your site;

    this is what the theme outputs as #header style into the <head> section:

    div#header {
                background: url(http://schememagazine.com/wp-content/uploads/2012/07/Scheme-Magazine-Logo-black.jpg); height :230px; -moz-border-radius-topleft:6px;border-top-left-radius:6px;-moz-border-radius-topright:6px;border-top-right-radius:6px;
            }

    there is no ‘no-repeat’ in the background style; i.e. any background image will be tiled/repeated to fill the space automatically.

    edit functions.php;

    find:

    div#header {
                background: url(<?php header_image(); ?>); height :230px; -moz-border-radius-topleft:6px;border-top-left-radius:6px;-moz-border-radius-topright:6px;border-top-right-radius:6px;

    change to:

    div#header {
                background: url(<?php header_image(); ?>) no-repeat; height :230px; -moz-border-radius-topleft:6px;border-top-left-radius:6px;-moz-border-radius-topright:6px;border-top-right-radius:6px;

    for more background parameters such as background position, see http://www.w3schools.com/css/css_background.asp

    Sorry i am still confused? here is my header code

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" <?php language_attributes() ?>>
    <head profile="http://gmpg.org/xfn/11">
    <meta http-equiv="content-type" content="<?php bloginfo('html_type') ?>; charset=<?php bloginfo('charset') ?>" />
    <meta name="viewport" content="width=device-width" />
    <title><?php bloginfo('name'); wp_title();?></title>
    <link rel="stylesheet" type="text/css" href="<?php bloginfo('stylesheet_url'); ?>" />
    <link rel="pingback" href="<?php bloginfo('pingback_url') ?>" />
    <link rel="shortcut icon" href="/favicon.ico" />
    <?php if ( is_singular() ) wp_enqueue_script( 'comment-reply' ); ?>
    <?php wp_head() ?>
    
    </head>
    
    <body <?php body_class(); ?>>
    <?php if (function_exists('AWM_generate_linking_code'))AWM_generate_linking_code(); ?> 
    
    <div id="wrapperpub" class="container">
    	<div id="header">
    		<div class="sixteen columns">
    			<h1 id="blog-title" class="blogtitle"><a href="<?php echo home_url( '/' ); ?>" title="<?php bloginfo('name') ?>"><?php bloginfo('name') ?></a></h1>
    			<div class="description"><?php bloginfo('description'); ?> </div>
    		</div><!-- sixteen columns -->
    	</div><!--  #header -->
    </div><!--  #wrapperpub -->
    <div class="clear"></div>
    <div id="wrapper" class="container">
    		<div id="access" class="sixteen columns">
    			<?php wp_nav_menu(array( 'container_class' => 'menu-header', 'theme_location' => 'primary-menu',)); ?>
    		</div><!--  #access -->
    <div class="clear"></div>

    Moderator Michael

    @alchymyth

    Forum Moderator

    why are you posting the code of header.php?

    I suggested:

    edit functions.php;

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Header shows twice?’ is closed to new replies.