Support » Plugin: HTTP Headers » Header Settings Blocking WordPress and Youtube

  • Resolved Steve Little

    (@big-steve)


    I have 2 issues currently:

    1. A youtube video that is embedded on the home page [https://www.ovenrestore.com.au] (scroll to the bottom) is being blocked.

    Message: http://www.youtube.com is blocked Requests to the server have been blocked by an extension. Try disabling your extensions. ERR_BLOCKED_BY_CLIENT

    2. From within the Dashboard –> Plugins when I click on the ‘view details’ for any plugin this is blocked.

    https://imgur.com/IabCgjE
    Message: http://www.ovenrestore.com.au is blocked http://www.ovenrestore.com.au refused to connect. ERR_BLOCKED_BY_RESPONSE

    I did make some manual changes based on the report from https://sitecheck.sucuri.net/results/ovenrestore.com.au.

    1. X-Content-Type-Options – nosniff On
    2. Strict-Transport-Security – max-age=63072000 On
    3. Content-Security-Policy – frame-ancestors ‘none’; object-src ‘self’; frame-src ‘self’; base-uri ‘self’

    I have yet to do some research to find out what the relationship is between YouTube & WordPress and HTTP headers – thought I would ask first.

    Many Thanks
    Steve L

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Dimitar Ivanov

    (@zinoui)

    Hi Steve,

    Go to HTTP Headers -> Security >> Content-Security-Policy

    Then, under the frame-src directive input the https://www.youtube.com into the text field.

    Sorry been busy with a security issue.

    Will take a look today. I guess the same applies to https://www.wordpress.org ?

    Thanks
    STeve L

    Hi, this solves the YouTube issue however, the other issue I think requires a different adjustment. It appears to be specific to the ‘view details’ link within plugins. Mind you if I open the same link in a new tab or window it works.

    Steve

    Hi,

    Solved this second issue with the popup link within the WordPress plugins list.

    Under the sandbox option in sandbox allow-popups;

    Thanks for the help.

    Steve L

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.