Support » Fixing WordPress » Header image won't upload.

  • Resolved Mascole07


    I try to change the header via the custom header link in appearance, i’m able to get as far as the crop and publish page but when I click ok (i’ve tried both options ‘use image as is and publish’ and ‘crop and publish’) it doesn’t load, all I get is a white page. Also on occasion I get a html error when I try to upload an image via the media uploader.

    everything was working fine until I updated to the latest wordpress a couple of days ago.

    I have checked my media settings, changed the permissions, reinstalled and rolled back wordpress, deactivating and uninstalling all plugins, I’ve tried uploading the image directly to cpanel but no luck.

    Here is a link to what I am getting–>

Viewing 12 replies - 1 through 12 (of 12 total)
  • Have you tried deactivating all plugins and switching to the default theme to see if any are causing that to occur?

    stupid question, but have you tried clearing out your cache on your browser?

    also, are your plugins still disabled, or did you turn them back on?

    Thanks for replying,

    I have tried disabling and deactivating all plugins as well as switching themes, I’ve tried twenty eleven, twenty twelve and twenty thirteen. this is a clean install of wordpress.

    Link to your site?


    There are no plugins installed at this time bar askimet and it is deactivated.

    You’ve checked the file permissions? Have you asked your hosting company?

    Yep checked permissions and tried different combos but no luck. I have emailed my host but they have yet to get back to me.

    Couldn’t have anything to do with the new update could it? Everything was working ok until I installed it.

    You’ve gone through this on the permissions?

    Updates do sometimes cause problems but if it was an actual WP bug, there’d be tons of people on these forums screaming! Where is your site hosted?

    Do you get any error messages? You should also ask your hosts how to look at the error logs for your site – to see what may be going on when that upload fails.

    BTW, can you upload other images?

    Have you tried a really small image?

    I’m also getting a html error when I try and drag and drop images through the media tab. Though when I go back in the images are there and I can use them in posts and pages just can’t get the header to work….

    Could this have something to do with my PHP memory?

    That usually shows up as a fatal error – something like “Allowed memory size of xxxxxx bytes exhausted”.

    You’ve said “html” error – is that actually “http”?

    Just an update for this problem.

    It was php memory limit and upload maximum file size limit that was causing the problem. I contacted my host and they were able to increase the limit. So if anyone is experiencing the same issue this is definitely worth trying.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Header image won't upload.’ is closed to new replies.