Support » Fixing WordPress » Header Image Problems

  • Resolved ThePlatypus



    I have a site at No matter how I muck with the code, I cannot get the header image to display as anything other than the gradient header you get with the Presentation > Header Image and Color tab. As you can see, I have now made this gradient all black for the time being.

    I have uploaded both kubrickheader.jpg and personalheader.jpg to the appropriate directory; however, neither shows up.

    I have another site at, which does not have this problem; I have successfully replaced the header image. At some point, I was frustrated enough to delete the entire wp-content folder of Diminished7 and replace it with the wp-content folder of Platypus; however, the problem remains, and I’m at a loss as to what to do. Thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Make sure the target image source refers to

    <?php bloginfo('template_directory'); ?>/images/yourimage.extension

    Actually I just noticed that my header image is appearing BENEATH the black rectangle, meaning that the header image is showing up. However, that built in gradient header still appears to be taking precedence. How do I disable that?

    I’m sorry to bump, but noone knows how to disable that gradient image?
    That’s the uri for your header.


    Thanks for replying. I did look at that url, and I looked inside the code for header.php – it seems that the code that places that into the page is “<?php wp_head(); ?>”. However, I don’t know how to edit that; looking at header-img.php, I still can’t determine how I would shut off the automatically generated gradient so that kubrickheader.jpg takes precedence.

    Suggest you take a look at the themes at – many of them are based on the default, but have done most of the hard work for you. Pick a theme that has the layout you like, then change the graphics and colors to your “look”.

    [Kubrick is NOT a good theme to try to “massage” to your own look.]

    It wasn’t a matter of massaging it to my own look, I was just attempting to disable the automatically generated gradient header.

    For the sake of anyone else that may have this problem in the future, it is done by using the advanced option and setting the colors to “default.”

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Header Image Problems’ is closed to new replies.