Support » Plugin: Elementor Header & Footer Builder » header footer elementor plugin not working with Elementor plugin

  • Resolved taraana

    (@taraana)


    Hi,

    I am using the header footer elementor plugin with elementor page builder. It was working last week however; it wasnt working when I tried yessterday. I was not able to load the ‘edit with elementor’ page (on elementor) while header footer elementor plugin was activated but could do it when it was deactivated.

    I reported this to the elementor page builder aurthor. They asked me to inform the header footer elementor plugin author as well.

    Thank you for your help.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Nikhil Chavan

    (@nikschavan)

    Hello @taraana,

    Is there any error that you are seeing when you click on the edit with elementor?

    Can you grab a screenshot of any error message you get? also, a screenshot of your browser console will be helpful to check if there are any JavaScript errors.

    Hi, I have disabled the restriction for now. You should be able to view it now. Thank you.

    Thread Starter taraana

    (@taraana)

    Hi Nikhil,
    Its working now. Thank you for your quick response and support.
    Tara

    • This reply was modified 3 years, 11 months ago by taraana.

    I am having exactly the same issue, but I do not understand how you have resolved it. What is this ‘restriction’ that has been disabled please?

    • This reply was modified 3 years, 10 months ago by ripgill.

    Hello Nikhil,

    I have the same issue as well.
    If I enable header footer elementor, I can’t start Elementor in AE Templates, Posts, Elementor Library, etc.

    I get a Java error in my console:

    JQMIGRATE: Migrate is installed with logging active, version 1.4.1
    jquery.smartmenus.js?ver=1.0.1:667 Uncaught TypeError: Cannot read property 'parentNode' of null
        at $.SmartMenus.menuInit (jquery.smartmenus.js?ver=1.0.1:667)
        at HTMLUListElement.<anonymous> (jquery.smartmenus.js?ver=1.0.1:191)
        at Function.each (jquery.js?ver=1.12.4:2)
        at jQuery.fn.init.each (jquery.js?ver=1.12.4:2)
        at $.SmartMenus.init (jquery.smartmenus.js?ver=1.0.1:191)
        at new $.SmartMenus (jquery.smartmenus.js?ver=1.0.1:116)
        at HTMLDivElement.<anonymous> (jquery.smartmenus.js?ver=1.0.1:1176)
        at Function.each (jquery.js?ver=1.12.4:2)
        at jQuery.fn.init.each (jquery.js?ver=1.12.4:2)
        at jQuery.fn.init.$.fn.smartmenus (jquery.smartmenus.js?ver=1.0.1:1175)
    menuInit @ jquery.smartmenus.js?ver=1.0.1:667
    (anonymous) @ jquery.smartmenus.js?ver=1.0.1:191
    each @ jquery.js?ver=1.12.4:2
    each @ jquery.js?ver=1.12.4:2
    init @ jquery.smartmenus.js?ver=1.0.1:191
    $.SmartMenus @ jquery.smartmenus.js?ver=1.0.1:116
    (anonymous) @ jquery.smartmenus.js?ver=1.0.1:1176
    each @ jquery.js?ver=1.12.4:2
    each @ jquery.js?ver=1.12.4:2
    $.fn.smartmenus @ jquery.smartmenus.js?ver=1.0.1:1175
    onInit @ frontend.js?ver=1.9.5:sourcemap:1050
    self.(anonymous function) @ frontend.js?ver=1.8.2:sourcemap:2193
    Module.trigger @ frontend.js?ver=1.8.2:sourcemap:2309
    self.(anonymous function) @ frontend.js?ver=1.8.2:sourcemap:2193
    init @ frontend.js?ver=1.8.2:sourcemap:2215
    Module @ frontend.js?ver=1.8.2:sourcemap:2323
    child @ frontend.js?ver=1.8.2:sourcemap:2339
    child @ frontend.js?ver=1.8.2:sourcemap:2339
    child @ frontend.js?ver=1.8.2:sourcemap:2339
    module.exports @ frontend.js?ver=1.9.5:sourcemap:1069
    _runHook @ frontend.js?ver=1.8.2:sourcemap:2007
    doAction @ frontend.js?ver=1.8.2:sourcemap:2040
    ElementsHandler.runReadyTrigger @ frontend.js?ver=1.8.2:sourcemap:91
    (anonymous) @ frontend.js?ver=1.8.2:sourcemap:47
    each @ jquery.js?ver=1.12.4:2
    each @ jquery.js?ver=1.12.4:2
    runElementsHandlers @ frontend.js?ver=1.8.2:sourcemap:46
    ElementsHandler.initHandlers @ frontend.js?ver=1.8.2:sourcemap:62
    initFrontend @ editor.js?ver=1.8.2:1720
    onPreviewLoaded @ editor.js?ver=1.8.2:1974
    dispatch @ jquery.js?ver=1.12.4:3
    r.handle @ jquery.js?ver=1.12.4:3

    And in my debug log I have several lines with the error:
    Cannot assign an empty string to a string offset in class.wp-scripts.php

    Can you help here?

    Thanks,
    Kindest regards,
    Robert

    • This reply was modified 3 years, 10 months ago by 4csmedia.

    Hello I am having the same issue with my site. I thought it could have been the latest update that rolled out two days ago, but I was using it successfully this morning. I am really puzzled at this because nothing was really changed on the site when it stopped working, I saved one page went to edit another one and it hung on the load screen. I have tried reinstalling, both the current version, and 1.0.5 and nothing has worked so far. I am getting errors similar to 4csmedia. If it would be helpful to get a copy paste of my errors let me know and I will get whatever you need.

    Thanks,
    Travis

    Plugin Author Nikhil Chavan

    (@nikschavan)

    Hey @travispalmer, @4csmedia Can you post a link to your website where I can see this problem?
    Are there any steps to reproduce this so that I will be able to suggest a solution to this problem?

    I am guessing this must be conflict from some other plugin as this plugin itself does not load a much code.

    Hello Nikhil, sorry for the delay in response. We ended up switching hosts and rebuilding the site using a different theme. Previously we were using GeneratePress and one day we just weren’t able to load the elementor editor on any page that had content edited in Elementor Header Footer on the page. We could still edit the header and footer themselves using elementor, but not any of our regular pages. I would post a link if we hadnt switched sites. I am fairly certain there was some bug with elementor header footer, because I deactivated all the plug ins one by one to find the issue.

    Anyways the plugin is working excellent for me now on OceanWP theme with everything else nearly the same as before. I just wanted to leave what information I could in case it helps resolve the issue for anyone else

    Hi Nikhil Chavan i got problem with h/footer builder.
    I use elementor elementor pro and h/footer builder.
    Problem is that i want to keep Astra theme footer true site.
    When enabling h/footer builder, my footer(astra) disapeared.
    On local everything is ok, got footer with h/footer and Astra footer.
    However uploading child theme etc won’t work. On server i coul’d get elementor loaded it stays loading. So i roll back elementor to 1.9.3 and now i can edit, but no footer, no header, if i will make header then elementor keeps loading and give error, sorry for bad english i must translate. It says the preview could not be loaded werĂ© sorry etc etc. So now i can not do anything annymore.

    Points are:

    Want to use Astra theme (since there is no way to set a menu in footer with elementor pro, i don’t want hamburger icon in my footer when scaling to mobile)
    Want to use h/footer builder without error’s.

    I have tried switch theme, unload child etc etc..

    Please help

    Plugin Author Nikhil Chavan

    (@nikschavan)

    Hey @perropura,

    Can you open up a new issue as this one is already resolved.

    Can you also add a screenshot of your developer console in browser? (right click -> inspect -> console) if there are any errors.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘header footer elementor plugin not working with Elementor plugin’ is closed to new replies.