[resolved] Header Custom Images with domain mapping (3 posts)

  1. branklam
    Posted 3 years ago #


    I am running a network of wordpress sites, and have been using your theme (thanks by the way).

    I recently used domain mapping to change the site from a subdomain to its own domain name. The issue I've run into is that all the links for my custom header are still pointed to the original domain.

    What makes me believe this may be an elegant white issue, is that in the media library for this site (where the header images are) they still appear and are usable. I would try to remove the broken custom images, but I don't see any way of doing that except by removing the files completely from the media library. I generated the images by uploading and cropping them using the header options page.

    I poked around a little bit in the theme editor, but I'm just not as familiar as you folks would be with it to determine where the image locations for custom headers is declared/stored. I looked in header.php and /inc/custom_header.php, I see where the images you included with your theme are declared, but not custom ones.

    Long story short, I am looking for direction as to how to either remove the custom header links without removing them from the media library, in the hopes I can re-add them now that the site is migrated to the new domain (I have quite a few custom cropped in there), or if there is some fix I can apply wherever you are declaring the custom image locations in your theme.

    Thanks so much for your time, and thanks again for this theme!

  2. branklam
    Posted 3 years ago #

    I was able to manually edit the database to change the file links, this probably isn't worth your time as it's a specialized problem, and may not truly even be a theme problem but a domain mapping incompatibablity.


  3. textweaver
    Posted 3 years ago #

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic