Support » Theme: Blocksy » Header color cleared after new update

  • Resolved dezajno

    (@dezajno)


    Hi,

    we’re using blocksy and really like it, but the newest update caused our header background color to be cleared. Also, a text appeared on the right of the logo. The latter was fixable through the logo settings. However, we’re not able to access the settings of the “Global Header” anymore: when going to customize > header > headers and clicking on “Global Header”, nothing happens. Any suggestions on how to fix this?

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Same issue here. Lot’s of repeating JS errors when opening the customizer.

    Here’s a screenshot of the error:
    https://snipboard.io/5owiTt.jpg

    Theme Author creativethemeshq

    (@creativethemeshq)

    Hi @dezajno, in the last update we removed the global background color option and now you can set the background only per one row, this was done like this in order to better handle the transparent & sticky states.
    The text that appeared in the logo is actually your site title, we added it because a lot of users asked this functionality.
    If you are using an image logo that simply deactivate the site title option from here.

    What do you mean you can’t access the options of the Global Header?
    This works fine on our end, please see this video

    Could you please submit a support ticket and give us temporary login access so we could investigate this more detailed?

    Theme Author creativethemeshq

    (@creativethemeshq)

    Hi @morganhvidt, did you tried to clear/purge your chaches?
    What caching plugin are you using?

    Thanks for the answer.
    Changing the background color of the row instead of trying to set it for the whole header works perfectly fine, thank you very much for pointing that out.
    What I mean by “can’t access the options of the Global Header” is the following: When clicking on “Header” under “Global Options” and selecting the “Headers” tab, one item appears with a blue border around it: “Global Header”. However, when clicking it, nothing happens. This is like due to there being no configuration options anymore as you pointed out, but it is still confusing that nothing happens at all, especially considering that this was previously the way of changing the header background.

    To sum it up:
    The background of the Global Header cannot be changed directly anymore. Instead, one needs to access the settings of a specific row in the header, which then allows you to change the background color of this specific row.

    When accessing the Global Footer options, a hint appears, notifiying about this change. This does not happen (for us) when accessing the Global Header options.

    Theme Author creativethemeshq

    (@creativethemeshq)

    Hey @dezajno,

    Yes, we know about that. We had to drop the Background option from Global Header in favour of the background options for individual rows. This also accommodates change the background of the rows for the transparent and sticky states, which was very difficult to achieve with the background option for the whole header. And sometimes changes like these happen, to make room for better way of doing things.

    And yes, we know that nothing happens now when you click on the “Global Header” panel but we also didn’t wanted to add some options just for the sake of filling an empty space. Also, in future updates, this part of the UI that seems confusing now to you now, will be used for creating & editing multiple headers. And on click you’ll be able to change conditions for a header & move it to the working area.

    With Footer it’s lot simpler, since it doesn’t have advanced states like sticky & transparent.

    Hope that makes sense to you. Just wanted to let you know that we gave a lot of thoughts to this before we came up with the flow you currently see.

    Thanks a lot for those insights, this makes everything very comprehensible. Thanks again for your help in resolving my confusion about this. Please keep up the good work πŸ™‚

    • This reply was modified 4 months, 3 weeks ago by dezajno.
    Theme Author creativethemeshq

    (@creativethemeshq)

    Hey @dezajno, you’re welcome!
    Don’t hesitate to contact us if you have any other questions.

    Have a nice day πŸ˜‰

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.