WordPress.org

Forums

Head Cleaner JS Issue with Wp-Super-Cache (6 posts)

  1. solidnuts
    Member
    Posted 6 years ago #

    First I'd like to thank you for such a great plug-in, with it I've managed to cut down over 3sec on page loads.

    With that said I seem to have some issue with wp-super-cache and the header cleaner's js optimization features, it seems after sometime the js stops being included into the cached pages causing my "Featured Content Gallery" plugin not to load, only after i manually empty the super cache dose it start to work for sometime then it breaks again.

    I would love to figure out a solution for this and I'm willing to donate to get it resolved.

    Thank you.

    http://wordpress.org/extend/plugins/head-cleaner/

  2. wokamoto
    Member
    Posted 6 years ago #

    Please rewrite wp-super-cache/wp-cache-phase2.php (line 368).

    $protected_directories = array( $cache_path . 'head-cleaner', $cache_path . '.htaccess', $cache_path . 'meta', $cache_path . 'supercache' );

  3. solidnuts
    Member
    Posted 6 years ago #

    Hi, Thanks for trying to help me but unfornately that did not work.. the js stop being included into wp-super-cache's cached pages after some time i was forced to manualy clear wp-super-cache again for the js to load.

  4. wokamoto
    Member
    Posted 6 years ago #

    Sorry, I don't have time to sort out the conflict right now. Does anyone have any idea what it might be? .

  5. solidnuts
    Member
    Posted 6 years ago #

    Hi it seems the issue is with wp-super-cache and nothing to do with your plugin :)

    although i did notice this error in the log that you might want to check:

    Sat Mar 28 10:57:26 2009] [error] [client 91.124.169.116] PHP Warning: get_browser() [function.get-browser]: browscap ini directive not set in /home/qbrushes/public_html/wp-content/plugins/head-cleaner/head-cleaner.php on line 727

  6. wokamoto
    Member
    Posted 6 years ago #

    Hi, solidnuts.

    although i did notice this error in the log that you might want to check:

    Sat Mar 28 10:57:26 2009] [error] [client 91.124.169.116] PHP Warning: get_browser() [function.get-browser]: browscap ini directive not set in /home/qbrushes/public_html/wp-content/plugins/head-cleaner/head-cleaner.php on line 727

    In order for this to work, your browscap configuration setting in php.ini must point to the correct location of the browscap.ini file on your system.
    (see. http://jp2.php.net/manual/en/function.get-browser.php)

    Head Cleaner Ver.1.1.5 includes 'php_browscap.ini' .

Topic Closed

This topic has been closed to new replies.

About this Topic