Support » Plugin: Migration, Backup, Staging - WPvivid Backup and Migration Plugin » Having unknow problem went restore wpvivid backup file

  • Resolved netalab

    (@netalab)


    Hi I’m having a unknow problem went restore the backup file. I’m trying to migrate my website to a new domain but this happen went restore
    and I have try with other hosting and this error not happen but other error showing (time out error)

    Log created: 2021-09-08 09:01:57
    Type: restore
    [2021-09-08 09:01:57][notice]init restore data
    [2021-09-08 09:01:57][notice]Start restoring magniflex.takeyourstory.com_wpvivid-61372400b2676_2021-09-07-08-34_backup_all.part001.zip
    [2021-09-08 09:01:57][notice]extract root:/home/u754123482/domains/magniflex.my/public_html/wp-content/wpvividbackups/
    [2021-09-08 09:01:57][notice]start extracting file:/home/u754123482/domains/magniflex.my/public_html/wp-content/wpvividbackups/magniflex.takeyourstory.com_wpvivid-61372400b2676_2021-09-07-08-34_backup_all.part001.zip
    [2021-09-08 09:06:58][notice]clean file:/home/u754123482/domains/magniflex.my/public_html/wp-content/wpvividbackups/magniflex.takeyourstory.com_wpvivid-61372400b2676_2021-09-07-08-34_backup_uploads.part004.zip
    [2021-09-08 09:06:58][error]restore failed error unknown

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support tonyrobins

    (@tonyrobins)

    Hi @netalab

    Please try to modify the following settings:

    In WPvivid Advanced Settings:

    Change PHP script execution timeout for restore to 3600 seconds
    Change PHP Memory Limit for restore to 512 MB
    Save changes

    In the meantime, please check if the site is on a Litespeed server. Because on a Litespeed server, in order to optimize the network, the server will kill requests that exceed a certain time, for example, 30s. You can add the following rules to the .htaccess file to prevent Litespeed timeout:

    <IfModule Litespeed>
        RewriteEngine On
        RewriteRule .*-[E=noabort:1, E=noconntimeout:1]
    </IfModule>

    All the best,

    Thread Starter netalab

    (@netalab)

    I’m using the hostinger hosting and

    <IfModule Litespeed>
    RewriteEngine On
    RewriteRule .*-[E=noabort:1, E=noconntimeout:1]
    </IfModule>

    is already in the .htaccess file
    showing like

    # BEGIN LSCACHE
    # END LSCACHE
    # BEGIN NON_LSCACHE
    # END NON_LSCACHE
    # BEGIN WordPress
    <IfModule mod_expires.c>
    	ExpiresActive On
    	ExpiresByType image/jpg "access plus 1 year"
    	ExpiresByType image/jpeg "access plus 1 year"
    	ExpiresByType image/gif "access plus 1 year"
    	ExpiresByType image/png "access plus 1 year"
    	ExpiresByType text/css "access plus 1 month"
    	ExpiresByType application/pdf "access plus 1 month"
    	ExpiresByType text/javascript "access plus 1 month"
    	ExpiresByType image/x-icon "access plus 1 year"
    	ExpiresDefault "access plus 1 weeks"
    </IfModule>
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    # BEGIN WPvivid_Restore
    # The directives (lines) between "BEGIN WPvivid_Restore" and "END WPvivid_Restore" are
    # dynamically generated, and should only be modified via WordPress filters.
    # Any changes to the directives between these markers will be overwritten.
    <IfModule Litespeed>
    RewriteEngine On
    RewriteRule .* - [E=noabort:1, E=noconntimeout:1]
    </IfModule>
    # END WPvivid_Restore
    Plugin Support tonyrobins

    (@tonyrobins)

    @netalab

    Thank you for your update. That’s good! Then please try the other settings as I suggested.

    All the best,

    Thread Starter netalab

    (@netalab)

    have try all solution but still facing the same error (restore failed error unknown)

    Plugin Support tonyrobins

    (@tonyrobins)

    Hi @netalab

    From the restore log, the restore process was terminated by the server in 5 minutes.

    So, it is also recommended that you check(contact your web host if you are not the server manager) whether there are any settings on the server that are limiting the php running time to 5 minutes, for example, 

    1. php max execution time

    It is recommended to set the php max_execution_time in the php.ini file to at least 900s.

    2. fcgi

    If fcgi is enabled on the server, change the fcgi timeout to at least 900s.

    3. check and change other similar limits(if any) to allow more time for php scripts to execute.

    All the best,

    Plugin Support tonyrobins

    (@tonyrobins)

    Hi @netalab

    Since we haven’t heard from you for a while, I am going to mark the thread as resolved.

    Please feel free to let us know if you need any further assistance.

    All the best,

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.