Support » Theme: Colorskin » Having trouble with site favicon in some browers using this theme

  • kengr

    (@kengr)


    I’m having trouble getting the site icon (favicon) to appear in the browser tabs only on IE 11 and Microsoft Edge. The icon appears correctly in the browser tabs of other browsers.

    I have tried removing and re-adding the site icon (a 512×512 PNG image), and have tried clearing all browser caches, etc. to force a reload. But I can’t get the site icon to appear on the browser tabs of these two Microsoft browsers.

    The only things I can think of are (1) the two generated link tags in the head section are both rel=”icon” (shouldn’t one of them be rel=”shortcut icon”?) and (2) there is no type attribute in the two generated link tags (shouldn’t they be type=”image/x-icon”?).

    What I currently see in the page head section is (part of URL removed):

    
    <link rel="icon" href="https://blog.../cropped-Logo-006-512x512-4-32x32.png" sizes="32x32" />
    <link rel="icon" href="https://blog.../cropped-Logo-006-512x512-4-192x192.png" sizes="192x192" />
    

    I’m very new to WordPress, and am not a favicon expert. I’m just looking at the generated HTML source, and comparing it with a non-WordPress site I have that does display the favicon properly in the browser tabs of all browsers, including the Microsoft browsers. For example, on my non-WordPress home page, I have (part of URL removed):

    <link rel="icon" href="https://www.../favicon.ico" type="image/x-icon" />
    <link rel="shortcut icon" href="https://www.../favicon.ico" type="image/x-icon" />

    which works in all browsers.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Subrata Sarkar

    (@subrataemfluence)

    For me it happened a few times as well. First thing first. Please clear all cookies and cache of your IE browsers. If this doesn’t work, check if you have any caching plugin installed. If so, please deactivate it and recheck.

    Although, I am not sure what exactly the case for you but you can at least try the above things.

    Rendering a favicon is no different in WordPress. It works the same way as a simple HTML does. And what I have noticed in my cases, IE takes a bit longer that FF or Chrome to render favicons.

    Please let me know if this helps you at all.

    kengr

    (@kengr)

    Thanks for your suggestions.

    I have no plugins installed at all, and I cleared everything in both IE and Edge.

    On these browsers, I never get any favicon in the browser tab for my site that uses this WordPress theme. I have tried going to other WordPress-based sites (not mine), and I always get the favicon immediately. But when I go to my site, the favicon immediately switches to the generic IE favicon in IE, and a plain box favicon in Edge. So, the browsers are definitely picking up favicons. Just not for my specific site.

    When I have just a plain old HTML page (not on my WordPress/Colorskin site), and I use both the rel=”icon” and rel=”shortcut icon” links, I get my favicon every time in both browsers.

    Theme Author Dimitrakopoulos

    (@effpandim)

    The website you have got the theme is in a subdomain and in the main domain you have got an html page. Try to take away favicon from the html page or put the theme in the main domain and tell me if it works.

    kengr

    (@kengr)

    Thanks for your suggestions.

    I copied the favicon from the HTML page (on the mail site) into the root folder of the subdomain, but it had no effect.

    I cannot place the WordPress site/theme into the main domain, as that application (currently just an HTML page, but will be an ASP.NET site) will conflict with WordPress.

    The main domain and subdomain does not share any directories…they have their own separate roots on the host, so there is no intersection between them. The subdomain is a WordPress blog only. The main domain is going to be an ASP.NET web site.

    I will just live with this for now.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Having trouble with site favicon in some browers using this theme’ is closed to new replies.