WordPress.org

Support

Support » Plugins and Hacks » Having trouble getting it to work

Having trouble getting it to work

  • jackfalber
    Member

    @jackfalber

    Sorry, I’m not hugely technical, in fact not at all really. I was pleased with myself for installing your plugin into my wordpress site, but I can’t get it to work. This error comes up:

    Fatal error: Call to undefined function get_the_post_thumbnail() in /home/medavia/public_html/wp-content/plugins/simple-staff-list/_inc/admin-views.php on line 78

    I’m sure I just need a step-by-step guide to getting this working.

    Thanks very much.

    http://wordpress.org/extend/plugins/simple-staff-list/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Brett Shumaker
    Member

    @brettshumaker

    Hi Jack,

    That is actually an error that comes up because your theme (probably an older one) does not support post thumbnails. I’ll be pushing an update for the plugin this weekend that will prevent that error from popping up but you still won’t be able to add a staff photo.

    You can add the following line anywhere in your theme’s functions.php file:

    add_theme_support( 'post-thumbnails' );

    After you add that line, it should work. Let me know if you have trouble.

    You can read more about post-thumbnails here.

    jackfalber
    Member

    @jackfalber

    Thanks Brett

    I learned the hard way not to meddle with the functions.php file, but I’ll send the code to our I.T. chap.

    You’re very kind.

    Jack

    Plugin Author Brett Shumaker
    Member

    @brettshumaker

    Hi Jack,
    Did you get your issue resolved?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Having trouble getting it to work’ is closed to new replies.