Support » Plugin: WooCommerce » Having to manually change order status from published to processing

  • Resolved mike_in_md

    (@mike_in_md)


    Not sure why recently new orders and processing e-mails do not go out when I get an order. The only work around is to manually change order status from published to processing.

    Paypal and Stripe are communicating properly with WooCommerce, new order and processing E-mails go out just fine after I manual change WooCommerce order status from “published” to “processing”

    What’s causing this?

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • I ran into the same exact problem with my website. Starting from last friday.
    Was quite a shock this morning as it appeared as if there were no orders.

    Same problem here and I see a whole lot more people with the same problem.

    I’m now checking the orders to manually change their status depending on there choose of payment. This is very sensitive to mistakes as some payed and some didn’t (bank).

    Fixed now, guess they updated it!

    I have the same issue and it is not fixed for me… any idea what it could be?
    I use Mollie for payments.

    • This reply was modified 1 year, 10 months ago by dotpro.
    • This reply was modified 1 year, 10 months ago by dotpro.

    Still facing same issue any idea to fix it ?

    Thread Starter mike_in_md

    (@mike_in_md)

    I’m working now.

    Here’s what I noticed when I tried to fix this.

    1. When I logged into admin for WordPress, I noticed a message that the WooCommerce database needed to be updated. I clicked to update database, waited to see a completed successful status and waited to get another order to see if the problem went away. Received new 3 orders after database update. Problem did not go a way.

    2. Looked at my WooCommerce settings. Noticed big mistakes under General settings. The 1st error was that under general options – sell to specific locations I saw only Vietnam…Okay, I didn’t do that and corrected it…it now shows United States. The 2nd error was that the currency option was not US dollars. So, I fixed that too. Immediately all my new orders went directly to processing status.

    So, in conclusion, I suspect that for my case the WooCommerce database didn’t update properly when I upgraded and that also caused the settings to corrupt.

    If this answer helps resolve your situation please come back and update your status.

    • This reply was modified 1 year, 10 months ago by mike_in_md.

    Happy it got fixed for you by this, but my problem is the fact that I haven’t changed any settings. It suddenly started happening which is extremely strange. I think it has to do with the new WordPress settings. 🙁

    All,

    For me the problem also wasn’t resolved and I also didn’t change any settings.

    Having read the above I decided to throw away the country specific sales countries (Woocommerce Common Settings). In my case that was Belgium and the Netherlands. I saved this and then added them back again and saved this.

    After this the problem looks solved. Very strange. My orders are no longer stuck in “Published”.

    Hope this helps for you.

    Kind regards.

    nonchiedercilaparola

    (@nonchiedercilaparola)

    For me the problem isn’t resolved. I tried to do jauko’s trick but i have the same problem: after paypal payment status order doesn’t change.

    wc version 3.8.1 with disabled shipping and shipping calculation.

    sorry i writed on wrong post. Please not consider my post (i can’t see a way to delete it)

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Having to manually change order status from published to processing’ is closed to new replies.