WordPress.org

Support

Support » Plugins and Hacks » Widget Alias » [Resolved] Having this plugin enabled makes everything on the widget page disappear

[Resolved] Having this plugin enabled makes everything on the widget page disappear

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Mickey Kay

    @mcguive7

    Hmmm, that definitely shouldn’t happen. Can you please tell me more about your setup? What version of WP? Plugins? Maybe a screenshot so I can take a look? Thanks!

    kmcharityteam

    @kmcharityteam

    Hello, thanks for getting back to me!

    WordPress is 3.7.1

    Without the plugin on:
    http://i39.tinypic.com/1z1v7ex.png

    With the plugin on:
    http://i40.tinypic.com/vq73pi.png

    Plug-ins are:
    All In One SEO Pack
    Auto Submenu
    Better WP Security
    BruteProtect
    Custom Menu Wizard
    Custom Meta Widget
    Download Manager
    Email Address Encoder
    Enable Media Replace
    Gravity Forms
    iframe
    Media Tags
    NextGEN Gallery
    Post Types Order
    Quick Page/Post Redirect Plugin
    SF Social Login
    Tag Pages
    Video Sidebar Widgets
    Widget Alias
    Widget Logic
    WP-Optimize

    Our site is live so I haven’t tried turning all the other plugins off and slowly turning them back on yet (perhaps I should invest in a mirror site). However I have tried turning off all the plugins to do with widgets and it makes no difference.

    Plugin Author Mickey Kay

    @mcguive7

    Great, thanks. I can work on setting up a testing server with the plugins you’ve installed to test the issue, however that might take a bit of time to get to. In the meantime, if possible, it would helpful if you could see if any JavaScript errors are firing when your widgets page loads.

    No stress if that’s too much to ask, but it might help me get to the bottom of things faster. You can see if there are any JS errors by using Chrome’s inspect tool. You can get there quickly (on Mac) by pressing cmd + option + J, on the bottom you’ll see a little link for “Errors” and if you click there you’ll see any errors in red. Please let me know if you’re able to do this and you come across anything.

    Thanks!

    Hello!

    I created a test version of our website and turned off all the plugins except Widget Alias and the same problem occurs. There are no errors using the inspect tool. That one solitary widget remaining is not draggable and clicking Screen Options or Help doesn’t do anything except refresh the page.

    3.8.0 still the same issue unfortunately.

    Plugin Author Mickey Kay

    @mcguive7

    Hi there,

    I just tested the plugin with a brand new install and my widgets are showing up fine. Very peculiar. Can you tell me what theme you are using? Aside from the plugins you’ve got installed, is there anything else unique about your WP install I should know about? Any special config settings? I’m really sorry you’re encountering this issue – if I can get more info and duplicate it then I’ll get to work on a solution.

    Hello,

    My theme is Worldwide by Goodlayers http://themeforest.net/item/world-wide-responsive-magazine-wp-theme/4940421

    I have tried changing back to the default themes, Twenty Eleven etc and no difference. I will now try deleting Widget Alias and reinstalling and see what happens! 🙂

    I found another plugin that seems to have this issue for some people but they were talking about resetting and re-authenticating it, which I’m assuming is a function of the widget, not something you can do to any widget. http://wordpress.org/support/topic/plugin-causing-disappearing-widgets-admin-sidebar?replies=9

    Plugin Author Mickey Kay

    @mcguive7

    Thanks for putting so much effort into helping sort this out. If you reinstall the plugin, does anything change for you?

    No, unfortunately it’s just the same. It must be something about my htaccess file or my installation or something.. It’s just so strange that this is the only plugin it happens with. At one point we had Jetpack and it couldn’t display any stats and I worked out that one php file in one directory in my install was in UTF8 encoding instead of ANSI or something completely baffling.

    I have the same problem on WP 3.8.1 using the theme Hades (http://themes.themegoods.com/?theme=Hades) – I only get one widget showing after I activate Widget Alias.

    And I have no plugins in common with kmcharityteam either!

    Plugin Author Mickey Kay

    @mcguive7

    Very strange. Do you see any JavaScript errors in the console? If you can check this for me that’d be extremely helpful. Thanks.

    Plugin Author Mickey Kay

    @mcguive7

    Just wanted to follow up again. I’m still using this plugin on multiple sites and am unable to reproduce this issue. If you could provide me with any PHP and/or JavaScript errors you’re encountering, that would be super helpful for troubleshooting. Thanks!

    Plugin Author Mickey Kay

    @mcguive7

    I’m happy to report that after some serious trouble-shooting, the recently released version 1.4 should now totally solve this issue.

    It turns out there was a call to an undefined function that was only causing problems with certain themes and plugin setups. Version 1.4 removes this function call entirely, which should fix the issue.

    Please let me know if you encounter any other issues and I’ll be more than happy to take a look!

    That’s so cool, thank you for your hard work Mickey!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Having this plugin enabled makes everything on the widget page disappear’ is closed to new replies.
Skip to toolbar