Support » Fixing WordPress » Having rouble with site validation and the wrap displaying correctly in IE.

  • Hi all,

    I have posted before and had no luck with this IE bug. I have tried to go through and validate the site and make the revisions, but the DOCYPTE seems to not be registering and therefore I have a bunch of errors that don’t make sense.

    The site is and it is almost perfect as I see it in most browsers, but in IE, the site is aligned left, no background, and the layout of the elements contained int he wrap are not lining up correctly as tehy do in other browsers.

    Any help you can offer would eb greatly appreciated. I am a newbie and learning as I go, which I know is not the best way to go about it. I have been a designer for 14 years and feel that I need to learn web design and simple site creation to keep up with the market place.

    Thanks again for any help you can offer.

Viewing 5 replies - 1 through 5 (of 5 total)
  • oops, the link is

    Moderator kmessinger


    You have to get rid of this code,

    <style type="text/css"> #wrap #content {
    	background-color: #FEFEFE;

    which is loading before DOCTYPE. If anything loads before that IE will go into the quirks mode which in most cases is not good.

    Thanks, I tried that change and am still getting “No DOCTYPE Found” error in validation. This is messing up the rest of the validation.

    Here is the code:

    	global $doctype;
    	global $class;
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "">
    <html xmlns="" lang="en" xml:lang="en">
    <!--[if lt IE 7 ]> <html class="ie6" xmlns="" <?php language_attributes( $doctype ) ?> > <![endif]-->
    <!--[if IE 7 ]>    <html class="ie7" xmlns="" <?php language_attributes( $doctype ) ?> > <![endif]-->
    <!--[if IE 8 ]>    <html class="ie8" xmlns="" <?php language_attributes( $doctype ) ?> > <![endif]-->
    <!--[if IE 9 ]>    <html class="ie9" xmlns="" <?php language_attributes( $doctype ) ?> > <![endif]-->
    <!--[if (gt IE 9)|!(IE)]><!--> <html xmlns="" <?php language_attributes( $doctype ) ?> > <!--<![endif]-->
    	<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <!-- //////// Favicon ////////  -->
    <link href="<?php echo get_template_directory_uri(_layout/images/favicon.ico); ?>/favicon.ico" rel="shortcut icon" type="image/x-icon" />
    	<script type="text/javascript">
    		var themePath = '<?php echo get_template_directory_uri(); ?>';
    		var themeCufon = '<?php echo get_option( EWF_SETUP_THNAME.'_cufon', 'true'); ?>';
    		var themeSliderTimeout = <?php echo get_option( EWF_SETUP_THNAME.'_slider_timeout', '5000'); ?>;
    		var msg_newsletter_error = '<?php echo __('please enter a valid email...', EWF_SETUP_THEME_DOMAIN); ?>';
    		var msg_newsletter_label = '<?php echo __('subscribe to newsletter...', EWF_SETUP_THEME_DOMAIN); ?>';
    	<?php wp_head(); ?>
    <body <?php body_class($class); ?>>
    	<div id="wrap">
    			<link href="<?php echo get_template_directory_uri(); ?>/style-nojs.css" rel="stylesheet" type="text/css" />
    			<div class="nojs-warning"><strong><?php _e('JavaScript seems to be Disabled!', EWF_SETUP_THEME_DOMAIN); ?></strong> <?php  _e('Some of the website features are unavailable unless JavaScript is enabled.', EWF_SETUP_THEME_DOMAIN); ?></div>

    The validation says that there is no DOCTYPE declaration and unable to determine parse mode.


    Moderator kmessinger


    The css code is still there. I can’t tell where it is coming from. I show it in style.css, you main style sheet so it is getting a call from somewhere. Perhaps a page template with some inline css? An SEO plugin? In any event that is the problem.

    BTW, when posting more that 10 lines of code it is best to use and just post the url.

    Thanks! I have contacted the developer to see if they can help. I cannot seem to locate where that style code is coming from.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Having rouble with site validation and the wrap displaying correctly in IE.’ is closed to new replies.