Support » Fixing WordPress » Having problems uploading an image

  • Hi,

    I am getting a number of various errors when trying to upload an image to WordPress. There are the steps I’ve taken:

    1. Unable to create directory /var/www/html/website/wp-content/uploads/2012/09. Is your parent directory writable?
    – I recreated the uploads folder with permissions 777. Still unsuccessful.
    – I created the subfolders manually. Still unsuccessful.
    – I turned off the “Organize uploads by month and year” option.

    2. The uploaded file could not be moved to /var/www/html/website/wp-content/uploads.
    – I recreated the folder once again, with permissions 777. Unsuccessful.
    – I tried locating the error message in the wp-admin/includes/file.php, then appending getcwd() to the end of the message to find the current working directory. Nothing new printed, besides the same error.
    – I created a phpinfo file, was not able to make much out of it other than that my temp directory is writable, and that the user groups are correct.
    – Removed php open_basedir on my website.

    3. File now uploads according to the uploader, but the physical file cannot be seen in my uploads folder. This gives a broken image (ie. no thumbnail)

    I am pretty much at my wit’s end trying to solve this problem. I am the server administrator of my own LAMP server, and I have at least 3 other WordPress sites on this server, all of which have working uploads. Except this one. I have no idea why.

    Some clarification and direction will be much appreciated. Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Change your wp-content folder permission to 777 and then try.

    Hi Chandan,

    No that doesn’t work either.

    A few of our hosting clients have faced this issue when they’ve used all the space up in their hosting plan.

    So you may want to double check that and if so free up some space so WordPress can save the file somewhere.

    Hi rxhost,

    According to df -h, I have 410M free on my boot partition. So I don’t think that should be the problem…

    This is the full output of my df -h

    Filesystem            Size  Used Avail Use% Mounted on
                           50G   11G   39G  21% /
    tmpfs                1000M     0 1000M   0% /dev/shm
    /dev/sda1             485M   50M  410M  11% /boot
                           72G  843M   68G   2% /home

    It’s a strange problem indeed. In my haste I didn’t read you were running your own server.

    What I described is common in shared hosting environments.

    Not sure what else it could be at the moment. If i think of anything I will let you know.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Having problems uploading an image’ is closed to new replies.