Support » Plugin: Jetpack by WordPress.com » Having multiple Jetpack problems

  • Resolved Eclectablog

    (@eclectablog)


    Several months ago, when posting or updating posts at Eclectablog.com, I started seeing a white screen with a HTTP 500 error after publishing or updating a post. I have been working with Jetpack staff and so far haven’t sorted it out. Disabling all of the plugins didn’t help. Neither did changing themes (I use the Canvas Wootheme.)

    Liquid Web took a look at it and found these errors:

    Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/eclect01/public_html/wp-includes/functions.php on line 3560

    Notice: load_plugin_textdomain was called with an argument that is deprecated since version 2.7 with no alternative available. in /home/eclect01/public_html/wp-includes/functions.php on line 3510

    Also, Jetpack is no longer connected properly to WordPress. When I try to disconnect from WordPress, I get the white screen. I also cannot deactivate Jetpack unless I delete the Jetpack folder.

    Finally, this morning I activated the Protect module in Jetpack and lost the ability to access the dashboard (site stayed up, thankfully.) I followed the following steps to resolve the issue:

    – Renamed Jetpack plugin folder to “Jetpack_x”
    – Uploaded the patch plugin found at http://i.wpne.ws/aRoP (“jetpackme_force_deactivate_protect”)
    – Activated the new plugin
    – Reactivated Jetpack

    The instructions that I found here also said to:

    – Rename the jetpack plugin folder back 🙂
    – Reactivate

    Weirdly, things were working fine until I renamed the folder back to “jetpack_x”. I have no idea why. I still cannot disconnect or deactivate Jetpack.

    I’ve also noticed that now when I “Save Draft” with a new post, I don’t get the “preview” button though it does appear to save the draft.

    This is the list of plugins I am currently using:

    – AddThis Sharing Buttons
    – Advanced Excerpt
    – Akismet
    – Author Avatars List
    – Blogger 301 Redirect
    – Blogger to WordPress
    – Brute Force Login Protection
    – Compact Audio Player
    – Disqus Comment System
    – Disqus Notify Post/Page Author
    – Force Deactivate Protect
    – Jetpack by WordPress.com
    – Mailchimp
    – Media Library Assistant
    – Security-protection
    – Simple Local Avatars
    – Slideshow Gallery
    – Subscribe2
    – Subscribe2 widget
    – Tweet Blender
    – Twitter Widget Pro
    – WP Easy Paypal Payment Accept
    – WP Super Cache

    I’d love to resolve this because it’s also affecting the Site Stats in that I can’t see past data, likely due to not being properly connected to WordPress.

    https://wordpress.org/plugins/jetpack/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor csonnek

    (@csonnek)

    Jetpack Pyromancer 🚀

    Hi there!

    I have been working with Jetpack staff and so far haven’t sorted it out.

    My colleague Brandon emailed you yesterday and I’m going to direct you to continue your correspondence with us in that email thread as that already has all the information we’ve been working on so far. Please include the list of plugins above and any other information you haven’t already shared with us.

    Marking as resolved as we’re already assisting you via email.

    Okay, I have more to add. Since this morning’s playing around, now posting has gone wonky. When I “save draft” the first time, it takes me to a fresh, blank “new post” editing page. Going out to the “All Posts” page shows the one I saved the draft of in draft status. Subsequent “save draft” acts normally. It’s only the first time.

    Hitting “Preview” opens a new tab that starts to load the preview then the URL changes and it loads a second instance of the editing page in new tab. However, if I hold down the CTRL button while clicking the “Preview” button, it opens the preview normally.

    Finally, I decided to get rid of a bunch of the plugins that I don’t use. I got rid of:

    – Blogger to WordPress
    – Media Library Assistant
    – Security-protection
    – Tweet Blender

    However, when I tried to deactivate Slideshow Gallery, I got a series of error codes:

    Notice: WP_User->id was called with an argument that is deprecated since version 2.1! Use WP_User->ID instead. in /home/eclect01/public_html/wp-includes/functions.php on line 3508

    Warning: Cannot modify header information – headers already sent by (output started at /home/eclect01/public_html/wp-includes/functions.php:3508) in /home/eclect01/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 60

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/eclect01/public_html/wp-includes/functions.php on line 3391

    Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home/eclect01/public_html/wp-includes/functions.php on line 3391

    It also made a hash out of the plugins page in the dashboard, displaying it very oddly. I’d do a screenshot but it’s too large and sprawling. The left side bar has each button tripled in size and the right sidebar seems to large so gets shoved to the bottom.

    Not sure if it’s related but I was able to deactivate this plugin within the past month or so.

    Okay, thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Having multiple Jetpack problems’ is closed to new replies.