Support » Fixing WordPress » Having a lot of trouble with WordPress

  • midsummerlifedream

    (@midsummerlifedream)


    I run a blog using WordPress and while I consider myself a computer idiot, I’ve experienced no major issues that I couldn’t fix for 3 years – until now. I wrote and scheduled a blog post in November that was supposed to go up on the 30th of that month. It did not, which, fine, I manually posted. But, and I’m not sure why, this post seems to have just broken everything. Now, I can’t write new posts without this post coming up, and I can’t update, save drafts – nothing. It tells me there’s a json error. So I looked it up and it was recommended to revert to the Classic editor rather than the blocks, but that didn’t help at all. I went through to make sure everything was updated, and it says things are updated, but then if I reload, it makes things go out of date again. I’ve opened the site in three different browsers, and cleared my cache, so it’s not some weird memory thing.

    Then, in an act of desperation, I crashed my entire site – twice – the first time, just reverting back to factory reset of wordpress, the second (when that didn’t work), deleting wordpress entirely and doing a complete reinstall. First it popped up half the time, completely empty, and half the time as if I never crashed it at all. After hours more of messing with it, and fighting and such…my site is down to a generic stock theme and my posts, and nothing else. But at least it knows I took it down to that. I’ve tried to debug, but nothing is showing up as an issue. I still can’t approve any comments, write new posts, or update old posts.

    I have a second blog, also through WordPress, with mostly the same plugins, theme, etc, and am having no issues with it whatsoever.

    Any advice?

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi @midsummerlifedream. Sorry you’re having so many issues.

    Firstly, do you know if your site or web host is configured to use a cache of some kind? For example, Cloudfare or Varnish. It sounds to me like there may be an issue there.

    Secondly, what is the error that you get when you approve a comment, write a new post, or update an old post?

    Thread Starter midsummerlifedream

    (@midsummerlifedream)

    OK, I checked for a cache, and while my host does have one available, it’s deactivated, so that’s not it (I don’t have one on my website).

    When I approve or trash a comment, it looks like it went through, but then never actually goes through. When I try to start a new post or update an old post, two things can happen. One, if I try to open a new post or a draft, around 50% of the time, it works, the other 50% it opens the last post I published (which I’ve now deleted, but it’s still getting opened). And then when I try to save or update, it says updating failed. It used to say updating failed -1, but now it’s just updating failed.

    Does your host have an object cache? For example, Memcache. If so, does emptying or disabling it fix the problem? The symptoms you’re describing sound a lot like caching issues which is why I ask 🙂

    You can also try checking to see if there are any JavaScript errors in your browser. This guide shows how to view JavaScript errors:

    https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/#step-3-diagnosis

    Thread Starter midsummerlifedream

    (@midsummerlifedream)

    Ok, on step 3 of the javascript error diagnosis, this came up.

    DevTools failed to load SourceMap: Could not load content for chrome-extension://daojbmllmfmdnlpihlnikehmodgjogdk/include.preload.js.map: HTTP error: status code 404, net::ERR_UNKNOWN_URL_SCHEME
    load-scripts.php?c=1&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.6:5 JQMIGRATE: Migrate is installed, version 3.3.2
    DevTools failed to load SourceMap: Could not load content for chrome-extension://daojbmllmfmdnlpihlnikehmodgjogdk/include.postload.js.map: HTTP error: status code 404, net::ERR_UNKNOWN_URL_SCHEME
    edit.php:1 Access to XMLHttpRequest at ‘https://app-directory.s3.amazonaws.com/hootlet/launched-app-directory-apps.json’ from origin ‘https://midsummerlifedream.com’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource.
    jquery-2.0.2.min.js:5 GET https://app-directory.s3.amazonaws.com/hootlet/launched-app-directory-apps.json net::ERR_FAILED

    Now, I had source maps, but since taking everything down and putting it back up, I haven’t rebuilt them (at least not for SEO standards).

    Also, that’s only in one browser. The two other browsers I’m checking in are listing no issues, even though I’m actually experiencing the exact same issues.

    As far as caching, I use interserver to host. From what I can see, there’s no automatic caching set up, but maybe I’m missing something.

    Source maps are only a tool to make development easier and shouldn’t impact the functioning of your site.

    Let’s continue searching for the culprit… Could you please run through all of the troubleshooting steps outlined in this post?

    https://wordpress.org/support/topic/read-this-first-wordpress-5-6-master-list/#post-13760920

    Thread Starter midsummerlifedream

    (@midsummerlifedream)

    Ok, I flushed the cache options – it said there was nothing there, that it’s not activated, but just in case. We already did different browsers and the javascript check, and I redid – nothing changed. The site health check shows no issues. I deleted all themes and went to the WordPress default, but nothing else changed.

    I manually reinstalled WordPress. The “Hello World” post let me update it, but when I exited that, I was right back where I started. Old posts saying they were there, but not really there, things showing up and disappearing. However, if I catch it when it knows it’s been restarted, it does let me make new posts. So that’s something.

    inessa8

    (@inessa8)

    Hi,

    why I can’t save a draft and preview the page?
    And how to contact the customer service which supposed to give support 24/7 without any trouble to find how to do it?

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.